Closed Bug 80403 Opened 19 years ago Closed 18 years ago

Auto-complete ignores protocol part of URI, favours alphabetical sorting of domain portion of URI

Categories

(SeaMonkey :: Location Bar, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 78270

People

(Reporter: mgregan, Assigned: hewitt)

Details

From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)
BuildID:    2001050915

The protocol (e.g. http://) part of a URI does not seem to be considered when 
offering autocomplete choices. When completing to 
https://webmail.jadedirect.com, after having typed https://we I am presented 
with a number of non-HTTPS matches that are sorted first due to alphabetical 
order... it is useful that these are displayed, but they should be matched 
AFTER the more obvious https:// choices (in this case, the only one in my auto-
complete should be the one I was trying to go to)

Reproducible: Always
Steps to Reproduce:
1. Have some URIs in the auto-complete history that use http:// and https://, 
with the same first few letters (e.g. https://we and http://we.
2. Try to auto-complete to the https:// entry, and you will be presented with 
the http:// one first if it comes in higher alphabetical order.

Actual Results:  Typed https://we and the first autocompletion match was 
http://we...

Expected Results:  Auto-completed to https://webmail.jadedirect.com
reassign to hewitt for dupe/triage
Assignee: alecf → hewitt
Think this is a dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 78270 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
This bug is more closely related to Bug 87667 than Bug 78270. In this instance,
autocompletion is only looking at the last word instead of the entire URL.
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.