Crash with abort message: "X_FreeGC: BadGC (invalid GC parameter)" when loading MozTrap with Mesa 7.10

RESOLVED DUPLICATE of bug 799544

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED DUPLICATE of bug 799544
5 years ago
4 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

({crash})

Trunk
All
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: webgl-driver, crash signature)

(Reporter)

Description

5 years ago
With the latest mozilla-central build on 64-bit Linux I get a reproducible crash when I load https://moztrap.mozilla.org/

Example crash report:
https://crash-stats.mozilla.com/report/index/bp-bd2a6cc1-7c6e-4a68-b7e3-421b92121022

Comment 1

5 years ago
Same as bug 799544 with other STR.
It's bug 717663 that is a dupe of bug 589546 closed as WFM because of Mesa 7.11.2.
Component: General → Canvas: WebGL
Product: Firefox → Core
Summary: Crash @ [mozalloc_abort | NS_DebugBreak_P | X11Error] when loading MozTrap → Crash with abort message: "X_FreeGC: BadGC (invalid GC parameter)" when loading MozTrap with Mesa 7.10

Comment 2

5 years ago
Should we dupe it to bug 799544?

Updated

5 years ago
Crash Signature: [@ mozalloc_abort | NS_DebugBreak_P | X11Error] → [@ mozalloc_abort | NS_DebugBreak_P | X11Error] [@ mozalloc_abort(char const*) | NS_DebugBreak_P | X11Error]
Can we mark this as dupe?
Flags: needinfo?(anthony.s.hughes)
Whiteboard: webgl-driver
(Reporter)

Comment 4

4 years ago
(In reply to Jeff Gilbert [:jgilbert] from comment #3)
> Can we mark this as dupe?

Done.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(anthony.s.hughes)
Resolution: --- → DUPLICATE
Duplicate of bug: 799544
You need to log in before you can comment on or make changes to this bug.