form (post) submission does nothing

VERIFIED FIXED

Status

()

Core
Networking
--
blocker
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Dan Rosen, Assigned: Darin Fisher)

Tracking

({regression, smoketest})

Trunk
x86
Linux
regression, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
In a tip build following darin's cache landing this afternoon, form submission
(the bugzilla "create attachment" form, in particular) does nothing. I see the
throbber animate for a brief moment, but it then stops and nothing else happens.
(Reporter)

Comment 1

17 years ago
i'm seeing this on linux, btw, but it's likely xp...
Keywords: smoketest
(Reporter)

Comment 2

17 years ago
hm, seems to be only form POST -- other forms seem to work fine.
Summary: form submission does nothing → form (post) submission does nothing
(Reporter)

Comment 3

17 years ago
alright, i'm a little confused. i'm able to post some forms (like "add a
comment" on tinderbox), just not the "create attachment" form. i'm not sure what
exactly the problem is. i'm leaving this as a smoketest blocker for the moment,
though...

Comment 4

17 years ago
could be the form enctype?

Comment 5

17 years ago
*** Bug 80471 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
I cannot attach a patch with mozilla, both linux & w2k.
Works for 4.7 on those platforms.
Keywords: regression
(Assignee)

Comment 7

17 years ago
this is mine... it's a simple fix to nsNetUtil.h that only affects file uploads.
Assignee: rods → darin
Component: Form Submission → Networking
(Assignee)

Comment 8

17 years ago
Created attachment 34347 [details] [diff] [review]
nsNetUtil.h patch
(Assignee)

Comment 9

17 years ago
Created attachment 34348 [details] [diff] [review]
fixes nsFormFrame.cpp
(Assignee)

Comment 10

17 years ago
the above two patches are both important to cover this bug.

Comment 11

17 years ago
r=pavlov
(Assignee)

Comment 12

17 years ago
turns out we were trying to ReadSegments on a raw file stream, so the simple
solution is to wrap the file stream with a buffered stream.
sr=jst
(Assignee)

Comment 14

17 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 77241 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Verifying on build 2001-05-17-08-trunk Linux RedHat 6.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.