Closed Bug 804256 Opened 7 years ago Closed 6 years ago

[Gaia::Dialer] Dialer Transition Not Implemented According to Spec

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P3)

All
Other
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: pla, Unassigned)

References

Details

(Whiteboard: visual design, UX P1, TEF_REQ, visual-tracking, ux-most-wanted-nov2014)

Please refer to page 7 of the following document:
https://www.dropbox.com/s/5xbazzqs8i9vnji/Transitions_v10.pdf

The transition to the dialer screen is different than what is spec'd.

Also, when typing the number in, the pressed key should highlight (white text on blue background).  Highlight colour hex code is #00abcd.
Tested on: otoro_2012-10-22_ics_us
Can you please be more specific about what's different than the spec?
Needs correct transition implemented. See latest transition document for correct behaviour.

https://www.dropbox.com/sh/hcpn9opc593l7tx/7zqGtV_inH
Priority: -- → P3
Component: Gaia → Gaia::Dialer
Keywords: perf
Summary: [transition] Dialer Transition Not Implemented According to Spec → [Gaia::Dialer] Dialer Transition Not Implemented According to Spec
Assignee: nobody → gtorodelvalle
Duplicate of this bug: 804267
Duplicate of this bug: 817702
Keywords: polish
Whiteboard: visual design → visual design, UX P1
Whiteboard: visual design, UX P1 → visual design, UX P1, TEF_REQ
PLease refer to this link to find the already produced animation and its CSS code: http://buildingfirefoxos.com/transitions.html#calls
(In reply to Victoria Gerchinhoren from comment #6)
> PLease refer to this link to find the already produced animation and its CSS
> code: http://buildingfirefoxos.com/transitions.html#calls

Hi Peter, can you check to see if the transition is still incorrect?  I forgot to bring my micro to nano sim adapter so I can't test this right now. It also looks like the number text is still the wring color (blue, not white #00abcd)
Flags: needinfo?(pla)
Whiteboard: visual design, UX P1, TEF_REQ → visual design, UX P1, TEF_REQ, visual-tracking
Hey Eric,

I just checked a build from yesterday and the dialer transition that is shown in the link Vicky provided has not been implemented.  Currently, all it does it when you press the 'Call' icon, the active call screen will drop down from the top.  When you hang up, it will slide back up out of the screen.
Flags: needinfo?(pla)
Thanks for checking Peter!

Germán, is this something you can look into? Thanks!
Flags: needinfo?(gtorodelvalle)
Hi guys! As far as I know, Sergi was rethinking the Dialer (incoming and outgoing calls) transitions. Although I'll contact him personally on Monday to check on this, requesting info from him so this bug is not forgotten ;-)
Flags: needinfo?(gtorodelvalle) → needinfo?(sergiov)
Well, not rethinking, but i'm wondering if we can simplify these animations. I've been checking them and i don't think it makes a lot of sense to use different transitions for the dialer depending the app the user is using in that precise moment. We can't predict what he will be doing when receiving a call and if we try to go so deep in creating such an amount of animations for the same use case, we may be always missing some.

My proposal is to simplify this and just use the one labeled "Answering a call from home" for all cases. The animation is similar to the one used when the user opens an app.
Flags: needinfo?(sergiov)
Sergi, I'll contact you tomorrow at the office and I'll show you what we currently have but I totally agree and support your proposal ;-)
Leaving this bug unassigned since I am not currently working on it ;-)
Assignee: gtorodelvalle → nobody
I'll keep the transitions meta-bug (bug 849820) and I will contact Vicky and Sergi to check the status and priority of these bugs.
Ni? UX to determine if this is still valid after visual overhaul this year.
Flags: needinfo?(firefoxos-ux-bugzilla)
I can't see anything wrong with Dialer transitions. Resolving invalid. Will file new bugs if we see issues on 2.1 implementations.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
Resolution: --- → INVALID
Blocks: 994991
Whiteboard: visual design, UX P1, TEF_REQ, visual-tracking → visual design, UX P1, TEF_REQ, visual-tracking, ux-most-wanted-nov2014
You need to log in before you can comment on or make changes to this bug.