Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Allow reactivation from webpages of Social API

VERIFIED FIXED in Firefox 17

Status

()

Firefox
SocialAPI
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

Trunk
Firefox 19
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox17+ verified, firefox18+ verified, firefox19 verified)

Details

(Whiteboard: [Fx17])

Attachments

(1 attachment)

Created attachment 674357 [details] [diff] [review]
Patch

Bug 764869 implemented activation from content but required that the provider had not been previously activated before.

The attached patch will allow activation as long as the Social API is not already enabled, which seems the more correct scenario.

social.enabled implies social.active.
social.active does not imply social.enabled.
Attachment #674357 - Flags: review?(gavin.sharp)
Attachment #674357 - Flags: review?(felipc)
Comment on attachment 674357 [details] [diff] [review]
Patch

redirecting to shane
Attachment #674357 - Flags: review?(felipc) → review?(mixedpuppy)
The original intent here was that we didn't want to allow the provider to re-enable if the user had previously enabled it, but then actively disabled it (i.e. via the Tools menu), because there was some potential for abuse there (e.g. if the provider just fired the event on every page view, that would get annoying really quickly).

It's worth re-visiting since we've gotten feedback from Facebook that they'd like to have a way to offer to re-enabled the feature, which seems reasonable, but we shouldn't lose track of the possible downsides here. I'd like to get feedback from others before moving ahead with this.
I seem to keep running into issues like this...we need to know if the user took some action in content (e.g. event.isTrusted) without having to watch for multiple events.  Popup blocking does this, but not in a generic fashion.

I think in the case of a whitelisted provider, we have a relationship where we should be able to trust the provider to do the right thing.
Comment on attachment 674357 [details] [diff] [review]
Patch

This would be fine, pending some thought around avoiding abuse.  As well, we'll ensure that active is always true if enabled in bug 804242
Attachment #674357 - Flags: review?(mixedpuppy) → review+

Updated

5 years ago
tracking-firefox17: ? → +
tracking-firefox18: ? → +
Attachment #674357 - Flags: review?(gavin.sharp)
https://hg.mozilla.org/integration/mozilla-inbound/rev/fd7180e29211
Comment on attachment 674357 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: if a user deactivates the social api, they cannot reactivate from the social providers site anymore
Testing completed (on m-c, etc.): locally, just landed on inbound
Risk to taking this patch (and alternatives if risky): none expected
String or UUID changes made by this patch: none
Attachment #674357 - Flags: approval-mozilla-beta?
Attachment #674357 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/fd7180e29211
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Attachment #674357 - Flags: approval-mozilla-beta?
Attachment #674357 - Flags: approval-mozilla-beta+
Attachment #674357 - Flags: approval-mozilla-aurora?
Attachment #674357 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/79f275013a23
https://hg.mozilla.org/releases/mozilla-beta/rev/d9e500352f3d
status-firefox17: --- → fixed
status-firefox18: --- → fixed
status-firefox19: --- → fixed
Verified fixed across all branches.
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified
status-firefox18: fixed → verified
status-firefox19: fixed → verified
You need to log in before you can comment on or make changes to this bug.