Last Comment Bug 804944 - add preferences for sets of CSS prefixed properties
: add preferences for sets of CSS prefixed properties
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla19
Assigned To: David Baron :dbaron: ⌚️UTC-10
:
: Jet Villegas (:jet)
Mentors:
Depends on: 849656
Blocks: unprefix 845245 806068
  Show dependency treegraph
 
Reported: 2012-10-24 01:19 PDT by David Baron :dbaron: ⌚️UTC-10
Modified: 2013-03-14 05:31 PDT (History)
7 users (show)
ryanvm: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add preferences (defaulting to enabled, for now) to control whether certain prefixed aliases for CSS properties are supported, so that authors can have a way to test what happens when they're turned off in advance of our disabling them. () (6.63 KB, patch)
2012-10-24 01:21 PDT, David Baron :dbaron: ⌚️UTC-10
bzbarsky: review+
Details | Diff | Splinter Review
, patch 2: Also condition @-moz-keyframes parsing on the animations preference. (1.35 KB, patch)
2013-02-25 17:35 PST, David Baron :dbaron: ⌚️UTC-10
bzbarsky: review+
Details | Diff | Splinter Review

Description David Baron :dbaron: ⌚️UTC-10 2012-10-24 01:19:36 PDT
I want to add preferences for sets of prefixed properties (which are going to be among the more difficult prefixes to get rid of) as a way to ease the path towards disabling those prefixes.  This will allow:
 * authors (or other testers) to test what happens when the prefixed property support is removed
 * easy landing and backout of the final patch in case we have to slip it across releases
Comment 1 David Baron :dbaron: ⌚️UTC-10 2012-10-24 01:21:36 PDT
Created attachment 674585 [details] [diff] [review]
Add preferences (defaulting to enabled, for now) to control whether certain prefixed aliases for CSS properties are supported, so that authors can have a way to test what happens when they're turned off in advance of our disabling them.  ()
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2012-10-24 12:42:23 PDT
Comment on attachment 674585 [details] [diff] [review]
Add preferences (defaulting to enabled, for now) to control whether certain prefixed aliases for CSS properties are supported, so that authors can have a way to test what happens when they're turned off in advance of our disabling them.  ()

r=me
Comment 3 David Baron :dbaron: ⌚️UTC-10 2012-10-26 10:05:30 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3d0e95c83ee
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-10-26 19:10:47 PDT
https://hg.mozilla.org/mozilla-central/rev/f3d0e95c83ee

Should this have tests?
Comment 5 David Baron :dbaron: ⌚️UTC-10 2012-11-26 00:11:52 PST
FWIW, I plan to blog about this (assuming I remember) after it hits the release channel.
Comment 6 David Baron :dbaron: ⌚️UTC-10 2013-02-25 17:35:58 PST
Created attachment 718188 [details] [diff] [review]
, patch 2:  Also condition @-moz-keyframes parsing on the animations preference.
Comment 7 David Baron :dbaron: ⌚️UTC-10 2013-02-25 17:37:33 PST
Blog post:  http://dbaron.org/log/20130225-removing-prefixes
Comment 8 Anne (:annevk) 2013-02-26 02:13:18 PST
Ms2ger discovered (and I verified) that turning this on breaks styling of tabs in Firefox 20. :-(
Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2013-02-26 06:26:27 PST
Comment on attachment 718188 [details] [diff] [review]
, patch 2:  Also condition @-moz-keyframes parsing on the animations preference.

r=me
Comment 10 Boris Zbarsky [:bz] (still a bit busy) 2013-02-26 06:27:12 PST
> turning this on breaks styling of tabs in Firefox 20. :-(

Not surprising; our UI has a tendency to use -moz-prefixed stuff before the unprefixed versions are available.

The good news is that we can easily search-and-replace our UI. ;)
Comment 11 Kohei Yoshino [:kohei] 2013-02-27 04:40:46 PST
(In reply to David Baron [:dbaron] (don't cc:, use needinfo? instead) from comment #7)
> Blog post:  http://dbaron.org/log/20130225-removing-prefixes

Added the link: https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_19
Comment 12 David Baron :dbaron: ⌚️UTC-10 2013-03-10 12:44:42 PDT
patch 2 landed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6ff3de859ce3
Comment 13 David Baron :dbaron: ⌚️UTC-10 2013-03-10 12:55:09 PDT
er, backed out, because it depended on unlanded patches:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cc6c725d463d
Comment 14 Stefan Fleiter (:sfleiter) 2013-03-10 13:46:06 PDT
If this is backed out it probably should not be set to RESOLVED FIXED.
Comment 15 David Baron :dbaron: ⌚️UTC-10 2013-03-10 13:56:39 PDT
The bulk of it is still fixed, just the one thing I missed that's not.
Comment 16 David Baron :dbaron: ⌚️UTC-10 2013-03-13 09:59:55 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f5f4ef33fa06
Comment 17 Ed Morley [:emorley] 2013-03-14 05:31:12 PDT
https://hg.mozilla.org/mozilla-central/rev/f5f4ef33fa06

Note You need to log in before you can comment on or make changes to this bug.