Intermittent crashtests/459439-1.html | Exited with code -6 during test run after "Assertion failed: (r == 0), function cubeb_stream_destroy"

RESOLVED FIXED in Firefox 18

Status

()

defect
--
critical
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: philor, Assigned: kinetik)

Tracking

({assertion, intermittent-failure})

Trunk
mozilla19
x86_64
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox17 wontfix, firefox18 fixed, firefox19 fixed)

Details

(Whiteboard: [test which aborts the suite])

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=16447266&tree=Mozilla-Inbound
Rev4 MacOSX Lion 10.7 mozilla-inbound opt test crashtest on 2012-10-25 00:05:54 PDT for push 689834383fbb
slave: talos-r4-lion-080

REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/content/media/test/crashtests/459439-1.html | 429 / 2139 (20%)
REFTEST TEST-PASS | file:///Users/cltbld/talos-slave/test/build/reftest/tests/content/media/test/crashtests/459439-1.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
Assertion failed: (r == 0), function cubeb_stream_destroy, file ../../../../../media/libcubeb/src/cubeb_audiounit.c, line 231.
TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/content/media/test/crashtests/459439-1.html | Exited with code -6 during test run
Could be the same root cause as bug 778675, or fallout from the fix for it.
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
Posted patch patch v0Splinter Review
Attachment #675437 - Flags: review?(chris.double)
Attachment #675437 - Flags: review?(chris.double) → review+
https://hg.mozilla.org/mozilla-central/rev/5a4073fa0bbb
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 675437 [details] [diff] [review]
patch v0

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 768265
User impact if declined: fatal assertion in some rare cases
Testing completed (on m-c, etc.): yes, baked on m-c for approximately two weeks
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none

This is needed if bug 778675's patch is approved.
Attachment #675437 - Flags: approval-mozilla-beta?
Attachment #675437 - Flags: approval-mozilla-aurora?
Comment on attachment 675437 [details] [diff] [review]
patch v0

Too late for beta, but please go ahead with uplift to aurora before Monday 11/19 merge day.
Attachment #675437 - Flags: approval-mozilla-beta?
Attachment #675437 - Flags: approval-mozilla-beta-
Attachment #675437 - Flags: approval-mozilla-aurora?
Attachment #675437 - Flags: approval-mozilla-aurora+
Whiteboard: [orange][test which aborts the suite] → [test which aborts the suite]
You need to log in before you can comment on or make changes to this bug.