Intermittent 481136-1.html, 466945-1.html, 468763-1.html, 459439-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.")

RESOLVED FIXED in Firefox 18

Status

()

defect
--
critical
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: emorley, Assigned: kinetik)

Tracking

({assertion, intermittent-failure})

Trunk
mozilla19
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17 wontfix, firefox18 fixed, firefox19 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Reporter

Description

7 years ago
Rev4 MacOSX Lion 10.7 mozilla-inbound opt test crashtest on 2012-07-27 18:30:57 PDT for push 73113b32afac

slave: talos-r4-lion-015

https://tbpl.mozilla.org/php/getParsedLog.php?id=13925059&tree=Mozilla-Inbound

{
REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/content/media/test/crashtests/474744-1.html | 417 / 2099 (19%)
REFTEST TEST-PASS | file:///Users/cltbld/talos-slave/test/build/reftest/tests/content/media/test/crashtests/474744-1.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
REFTEST TEST-START | http://localhost:4444/1343439475907/3/481136-1.html | 418 / 2099 (19%)
Assertion failed: (r == 0), function cubeb_stream_init, file ../../../../../media/libcubeb/src/cubeb_audiounit.c, line 184.
TEST-UNEXPECTED-FAIL | http://localhost:4444/1343439475907/3/481136-1.html | Exited with code -6 during test run
}
Assignee

Updated

7 years ago
Blocks: 742160, 768265
Assignee

Comment 1

7 years ago
OpenAComponent is failing (http://mxr.mozilla.org/mozilla-central/source/media/libcubeb/src/cubeb_audiounit.c#184).  I can make that non-fatal, but I'm curious about *why* it's failing...
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
Reporter

Comment 2

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=14044568&tree=Mozilla-Inbound
Summary: Intermittent 481136-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.") → Intermittent 481136-1.html, 466945-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.")
Reporter

Comment 3

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=14063250&tree=Mozilla-Inbound
Summary: Intermittent 481136-1.html, 466945-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.") → Intermittent 481136-1.html, 466945-1.html, 468763-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.")
Assignee

Comment 4

7 years ago
Pushed some logging:

https://hg.mozilla.org/integration/mozilla-inbound/rev/c8f9da21bc88

Once this fails again, I'll look at the log and then make this non-fatal.
Assignee

Updated

7 years ago
Whiteboard: [orange] → [orange][leave open]
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 7

7 years ago
Oh, cute.  This time it failed on the next assert(r == 0), which I hadn't instrumented.  I suspect this is going to turn out to be an OOM situation...
Assignee

Updated

7 years ago
Summary: Intermittent 481136-1.html, 466945-1.html, 468763-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.") → [debug this] Intermittent 481136-1.html, 466945-1.html, 468763-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.")
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 11

7 years ago
(In reply to TinderboxPushlog Robot from comment #10)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=14963650&tree=Try

cubeb_audiounit: FATAL: AudioUnitSetProperty(SetRenderCallback) returned -4
Assertion failed: (r == 0), function cubeb_stream_init, file ../../../../../media/libcubeb/src/cubeb_audiounit.c, line 197.

AudioUnitSetProperty returns an OSStatus, which (according to MacErrors.h and /usr/bin/macerror) is unimpErr (unimplemented core routine).  I have no idea what that means in this context.  I'll wait for another failure or so and see if it's the same error in each case.
https://tbpl.mozilla.org/php/getParsedLog.php?id=15151242&tree=Mozilla-Inbound
Summary: [debug this] Intermittent 481136-1.html, 466945-1.html, 468763-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.") → [debug this] Intermittent 481136-1.html, 466945-1.html, 468763-1.html, 459439-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.")
Assignee

Comment 13

7 years ago
Same failure code from the same function that time.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 19

7 years ago
Posted patch patch v0Splinter Review
I have no idea what to do about these, so let's just make them non-fatal.
Attachment #672678 - Flags: review?(chris.double)
Assignee

Updated

7 years ago
Whiteboard: [orange][leave open] → [orange]
Assignee

Updated

7 years ago
Summary: [debug this] Intermittent 481136-1.html, 466945-1.html, 468763-1.html, 459439-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.") → Intermittent 481136-1.html, 466945-1.html, 468763-1.html, 459439-1.html | Exited with code -6 during test run ("Assertion failed: (r == 0), function cubeb_stream_init, file media/libcubeb/src/cubeb_audiounit.c, line 184.")

Updated

7 years ago
Attachment #672678 - Flags: review?(chris.double) → review+
Reporter

Comment 21

7 years ago
https://hg.mozilla.org/mozilla-central/rev/e0b2ebcbd56a
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Can we request approval to uplift this to aurora and beta please?
Assignee

Comment 25

7 years ago
Comment on attachment 672678 [details] [diff] [review]
patch v0

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 768265
User impact if declined: fatal assertion in some rare cases
Testing completed (on m-c, etc.): yes, baked on m-c for approximately a month
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none

We'll also want bug 805352's patch, which is the same but for cubeb_stream_shutdown.
Attachment #672678 - Flags: approval-mozilla-beta?
Attachment #672678 - Flags: approval-mozilla-aurora?
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment on attachment 672678 [details] [diff] [review]
patch v0

Too late for Beta, but go ahead with uplift to Aurora before Monday 11/19 merge.
Attachment #672678 - Flags: approval-mozilla-beta?
Attachment #672678 - Flags: approval-mozilla-beta-
Attachment #672678 - Flags: approval-mozilla-aurora?
Attachment #672678 - Flags: approval-mozilla-aurora+
Whiteboard: [orange]

Updated

7 years ago
Whiteboard: [qa-]
Comment hidden (Legacy TBPL/Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.