nsOutlinerBoxObject::RowCountChanged can behave incorrectly

RESOLVED FIXED in mozilla0.9.1

Status

()

Core
XUL
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Brian Ryner (not reading))

Tracking

Trunk
mozilla0.9.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
Calling rowCountChanged when you are removing rows and are not scrolled to the
top of the outliner can cause it to miscompute mTopRowIndex, which causes it to
ask the outliner view for the wrong row indices (which causes a totally
incorrect display).
(Assignee)

Updated

17 years ago
Blocks: 75838
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 2

17 years ago
Created attachment 34277 [details] [diff] [review]
oops, I really wanted PR_MAX
bryner, is this the bug where i got the wacky highlighting after double-clicking
a dir which had fewer contents than its parent?
(Assignee)

Comment 4

17 years ago
sairuh -- Yep, this is the root cause of the problem.

Comment 5

17 years ago
sr=hyatt
(Assignee)

Comment 7

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
I just built on Linux and now crash trying to wheelscroll in filepicker OR after
having selected a file and then wheelscrolling. Twice in a row in

nsCacheEntryHashTable::GetKey () from dist/bin/components/libnkcache.so

Using RH's gcc2.96-81 so perhaps not all see this but thought it worth mentioning.

Comment 9

17 years ago
Sorry. The crash is unrelated. (it's all over the place here - editing AB card,
opening in new window - even closing one.)
You need to log in before you can comment on or make changes to this bug.