Closed Bug 75838 Opened 20 years ago Closed 20 years ago

rewrite file picker to use outliner

Categories

(SeaMonkey :: UI Design, defect)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.2

People

(Reporter: bugzilla, Assigned: bryner)

References

Details

(Keywords: perf)

Attachments

(2 files)

summary sez it all. sorry, bryner --i couldn't find an existing bug for this. i
want to file this so that issues like bug 70628 can be duped [or, dependent if
necessary] against it.
Severity: normal → major
Keywords: nsbeta1, perf
I checked in a work-in-progress version of this rewrite.  To try it out:

cvs up -rOUTLINER_FILEPICKER_BRANCH themes/modern/global/filepicker.css
themes/classic/global/win/filepicker.css xpfe/components/filepicker/res/content

Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
In addition to the above files, you will also need to get xpfe/components/jar.mn
from the branch.
Blocks: 73948
Blocks: 72482
*** Bug 73509 has been marked as a duplicate of this bug. ***
Blocks: 69185
Depends on: 80543
*** Bug 72482 has been marked as a duplicate of this bug. ***
Not critical for beta, so moving to 0.9.2.  Brian says the work is done though,
so if reviews come in before Friday it would still be good to land this for beta.
Target Milestone: mozilla0.9.1 → mozilla0.9.2
I've looked at the stuff on the branch, it looks good. r=jag
Note that xpfe/components/filepicker/res/content/filepicker.css is also removed,
with this landing.
bryner: peter said you needed a hand landing this. how may i be of service? :)
outlinercell-inset-header on the outlinercols is unnecessary.  Also, some of 
the functions would be easier to read if they had more descriptive parameter 
names.

sr=blake with all the stuff we discussed...
i hate to say this but i'm not convinced this is ready yet...

i've seen some strange visual bugs including the list being entirely one file
name while it loads, the scrollbar not scrolling dynamically in directories with
many files, and weird jumpyness as the list comes in...

i've also had it lock up on me and this is all just with very basic usage...

the keyboard control feels slugish and the buttons don't feel quite right.

anyway this feels harsh and some of it is prob the limitations of xul and
outliner... not sure...
i approve, course it's already checked in but what they hey ;-)
branch is checked in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
vrfy fixed with verif and debug bits from 5/23. new/separate issues to separate
bugs. :)
Status: RESOLVED → VERIFIED
*** Bug 103476 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.