Closed Bug 805553 Opened 7 years ago Closed 7 years ago

Test Windows 8 SDK

Categories

(Infrastructure & Operations :: CIDuty, task, P2)

x86
macOS

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 806799

People

(Reporter: armenzg, Assigned: armenzg)

Details

No description provided.
Assignee: nobody → armenzg
I have triggered builds to show up in http://dev-master01.build.scl1.mozilla.com:8040/buildslaves/w64-ix-slave79?numbuilds=20
This will ensure that the slave is still good without anymore changes.

jimm, is there any code changes that would start using the Windows 8 SDK?
If so, can you please land it? Even on try. This way I can then trigger builds to pick those changes on staging.

I can modify the header manually for w64-ix-slave79.
(In reply to Armen Zambrano G. [:armenzg] from comment #1)
> jimm, is there any code changes that would start using the Windows 8 SDK?
> If so, can you please land it? Even on try. This way I can then trigger
> builds to pick those changes on staging.

Not that I'm aware of. For testing this what we can do is flip the metro builders over to vs 2010 and the 8.0 sdk. I was planning on filing a bug on this once I land the changes in bug 794983 on elm, which should be done here pretty soon.
Priority: -- → P2
I will block on bug 794983 until then.
Depends on: 794983
(In reply to Armen Zambrano G. [:armenzg] from comment #3)
> I will block on bug 794983 until then.

The backport is basically done. Just doing some testing now. Once it lands I'll file a bug on making changes to elm's custom vs2012 builders so we can switch them over to vs 2010 / 8.0 sdk. If that all goes well we should set the priority on this work appropriately. We'd like to get all builders migrated to the 8.0 sdk by year end so that metro bits can be turned on for normal nightly builds.
Depends on: 799121
Isn't this bug basically a dupe of bug 774910? If not, shouldn't it block bug 774910?
Changing the dependency.
I wanted to confine the releng work into one bug separating it from the discussions about 7.0/7.1/8.0.
I hope it makes sense.
No longer depends on: enable-8.0sdk
I will do the work on bug 806799 so I won't get myself confused.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 806799
No longer blocks: enable-8.0sdk
No longer depends on: 794983, 799121
Product: mozilla.org → Release Engineering
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.