IndexedDB warningQuota should be turned off for Android web apps

RESOLVED FIXED in Firefox 19

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cscott, Assigned: cscott)

Tracking

unspecified
Firefox 19
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Bug 757678 turned off the indexeddb warningQuota for desktop apps, and bug 711358 turned it off for b2g apps.  It should also be turned off for Android web apps.  Looks like an easy four-line (or so) patch, judging from the patch attached to bug 757678.
(Assignee)

Comment 1

5 years ago
Hm, I think that the 'offline-app' permission should also be given to webapps?  At least that's included in the context for https://hg.mozilla.org/integration/mozilla-inbound/rev/08d44c70e1cb (which fixed bug 757678, this bug's equivalent for desktop web apps).
(Assignee)

Comment 2

5 years ago
Created attachment 675250 [details] [diff] [review]
Proposed patch to match desktop webapp permissions.
Attachment #675250 - Flags: review?(wjohnston)
Attachment #675250 - Flags: review?(wjohnston) → review+
Duplicate of this bug: 796321
Status: UNCONFIRMED → NEW
Ever confirmed: true
cscott - You will need to convert the patch into something a check-in helper can land. If Wes has time, maybe he will just make the changes locally and land it. If that is the case, Wes only needs your name and email.
Tip: you can use

git show -M -C --binary --format="# HG changeset patch%n# User %an <%ae>%n%B" -U8

to export a patch that looks like it came from hg
Whoops. Lost this for a bit, but pushed it now

https://hg.mozilla.org/integration/mozilla-inbound/rev/123cb677c197
https://hg.mozilla.org/mozilla-central/rev/123cb677c197
Assignee: nobody → cscott
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
You need to log in before you can comment on or make changes to this bug.