Closed Bug 805573 Opened 7 years ago Closed 6 years ago

Day view (or Today) panes should automatically display first event within view instead of starting at midnight

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 1023663
tracking-b2g backlog

People

(Reporter: aaronmt, Unassigned, Mentored)

References

Details

(Keywords: b2g-testdriver, polish, unagi, Whiteboard: [LOE:S][interaction])

Attachments

(2 files)

Currently, when I open the Calendar, I wish to see all the events I have for the day. I have plenty of events which begin in the afternoon and I am required to scroll from midnight (12:00AM), all the way down. The current day should automatically scroll to the first event of the day and have it within view on the screen.
blocking-basecamp: ? → ---
Keywords: polish
QA Contact: tchung
Whiteboard: [mentor=jlal@mozilla.com][LOE:S]
I'll have a patch for that soon. But I have a question:
if there is no event that day, do we still want to start at midnight? 8 AM might more reasonable IMHO
Should start at current time of the date selected.
Priority: -- → P2
Whiteboard: [mentor=jlal@mozilla.com][LOE:S] → [mentor=jlal@mozilla.com][LOE:S][interaction]
Priority: P2 → P3
@Casey, even if it's not the current day?
Hello James,

Please help me by reviewing this attached patch(https://github.com/mozilla-b2g/gaia/pull/10638) :)

Thanks,
Attachment #767724 - Flags: review?(jlal)
Comment on attachment 767724 [details] [diff] [review]
Proposed patch for this bug.

Hi!

Thanks for working on this- I left some comments on github. When your ready for another round of review please set the review flag again.
Attachment #767724 - Flags: review?(jlal)
Comment on attachment 767724 [details] [diff] [review]
Proposed patch for this bug.


Hello James,

Thanks for reviewing the patch :)

I have incorporated changes as per your suggestions. Please review it again and let me know if any change is required.

Regards,
Attachment #767724 - Flags: review?(jlal)
Comment on attachment 767724 [details] [diff] [review]
Proposed patch for this bug.

Looks good! Final step is to write some tests... Please flag me again after you have some test coverage for the new methods and we should be good to land I think... Please reach out to me on IRC (or in the gaia channel in general) if you need help... Also see the gaia README.md
Attachment #767724 - Flags: review?(jlal)
Comment on attachment 767724 [details] [diff] [review]
Proposed patch for this bug.


Hello James,

I have written a test case for changes as per your suggestions. Please review it  and let me know if any change is required. :)

Regards,
Attachment #767724 - Flags: review?(jlal)
Comment on attachment 767724 [details] [diff] [review]
Proposed patch for this bug.

Sorry for the delay and thank you for this! I have a few small comments then we should be good to land this.
Attachment #767724 - Flags: review?(jlal) → review-
What's the status of this bug?
Blocks: 994991
blocking-b2g: --- → backlog
Whiteboard: [mentor=jlal@mozilla.com][LOE:S][interaction] → [mentor=jlal@mozilla.com][LOE:S][interaction][priority]
Mentor: jlal
Whiteboard: [mentor=jlal@mozilla.com][LOE:S][interaction][priority] → [LOE:S][interaction][priority]
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [LOE:S][interaction][priority] → [LOE:S][interaction]
Duplicate of bug: 1023663
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.