[User story] Calendar day view should start at 8 AM

VERIFIED FIXED in 2.1 S2 (15aug)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: skasetti, Assigned: evanxd)

Tracking

unspecified
2.1 S2 (15aug)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.1)

Details

(Whiteboard: [tako][p=7][2.1-feature-qa+])

User Story

As a user I want the day view to start at 8AM so it represents my working day.

Attachments

(2 attachments, 2 obsolete attachments)

Comment hidden (empty)

Comment 1

4 years ago
Created attachment 8448477 [details]
[2.1 Calendar] 8AM Day View_Draft.pdf

Updated

4 years ago
QA Contact: edchen
(Assignee)

Updated

4 years ago
Assignee: nobody → evanxd
Whiteboard: [tako]
Target Milestone: --- → 2.1 S1 (1aug)

Comment 2

4 years ago
Created attachment 8463766 [details]
[2.1 Calendar] 8AM Day View_v1.0.pdf
Attachment #8448477 - Attachment is obsolete: true
Mentor: jlal
Duplicate of this bug: 805573
Evan, you may want to take a look at the patch on Bug 805573 to see if that code can be re-used or incorporated into your fix here.
(Assignee)

Comment 5

4 years ago
Hi Dylan,

Thanks for this.

I was investigating the smooth scrolling things.
(Assignee)

Comment 6

4 years ago
Created attachment 8465321 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22352

Currently, the patch is for ui review. It is not ready for code review.
(Assignee)

Comment 7

4 years ago
Comment on attachment 8465321 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22352

Hi Harly,

Could you help to do the ui-review?

Thanks.
Attachment #8465321 - Flags: ui-review?(hhsu)
(Assignee)

Updated

4 years ago
Attachment #8465321 - Flags: ui-review?(hhsu)
(Assignee)

Updated

4 years ago
Attachment #8465321 - Flags: ui-review?(hhsu)

Comment 8

4 years ago
Created attachment 8466024 [details]
[2.1 Calendar] 8AM Day View_v1.1.pdf
Attachment #8463766 - Attachment is obsolete: true

Comment 9

4 years ago
Comment on attachment 8465321 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22352

Hi Evan, I have added a new spec to auto scroll to an hour before current time in current day view. Other than that, the patch looks great. Thanks!!
Attachment #8465321 - Flags: ui-review?(hhsu) → ui-review+
(Assignee)

Comment 10

4 years ago
Hi Harly,

I already updated the patch for the an hour before thing.
Thanks for the review.

Updated

4 years ago
Depends on: 1047279

Updated

4 years ago
Depends on: 1047283

Updated

4 years ago
Depends on: 1039983
(Assignee)

Comment 11

4 years ago
Hi Harly,

I think your meaning is these three bug depend on Bug 1023663.
No longer depends on: 1039983, 1047279, 1047283
(Assignee)

Updated

4 years ago
Whiteboard: [tako] → [tako][p=5]
(Assignee)

Comment 12

4 years ago
Comment on attachment 8465321 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22352

Hi Miller,

Could you help to review the patch?
I will add(fix) the related unit/marionette tests after the first round review.

Thanks.
Attachment #8465321 - Flags: review?(mmedeiros)
Comment on attachment 8465321 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22352

added a few comments about the code
Attachment #8465321 - Flags: review?(mmedeiros)

Updated

4 years ago
QA Whiteboard: [2.1-feature-qa+]
Hey guys this was targeted to land in sprint 1, is this moving along? Thanks
Flags: needinfo?(mmedeiros)
Flags: needinfo?(evanxd)
(Assignee)

Comment 15

4 years ago
Hi Candice,

We're doing code review now, and the ux review is done.
I think we could land this in this week.
Flags: needinfo?(evanxd)
Target Milestone: 2.1 S1 (1aug) → 2.1 S2 (15aug)

Updated

4 years ago
QA Whiteboard: [2.1-feature-qa+] → [COM=Productivity]

Updated

4 years ago
QA Whiteboard: [COM=Productivity] → [COM=Gaia::Calendar]

Updated

4 years ago
QA Whiteboard: [COM=Gaia::Calendar] → [COM=Gaia::Calendar][2.1-feature-qa+]
(Assignee)

Comment 16

4 years ago
Comment on attachment 8465321 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22352

Hi Miller,

If the patch[1] looks OK, I will add/fix the unit/marionette tests tomorrow.
And then I will send you review the test code again.

Thanks.

[1] https://github.com/mozilla-b2g/gaia/pull/22352
Attachment #8465321 - Flags: feedback?(mmedeiros)
Evan, the code is looking good! I did not spend too much time looking at the test tho since you said you had to fix/add some things. Thanks!
Flags: needinfo?(mmedeiros)
(Assignee)

Comment 18

4 years ago
Hi Harly and Peko,

For the scrolling effect, we could use the `ease` effect. How do you think?
Flags: needinfo?(pchen)
(Assignee)

Updated

4 years ago
Flags: needinfo?(hhsu)
Hi Evan,

yes, I agree with you.
The `ease` effect is better.
thanks!!
Flags: needinfo?(pchen)
(Assignee)

Updated

4 years ago
Mentor: jlal
Duplicate of this bug: 1047279

Comment 21

4 years ago
Thanks Evan,
The ease effect fell much better than the constant speed effect.
Thank you for adding it.
Flags: needinfo?(hhsu)
(Assignee)

Comment 22

4 years ago
Comment on attachment 8465321 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22352

Hi Miller,

I updated for the comments.
Could you help to review the patch?

Thanks.
Attachment #8465321 - Flags: feedback?(mmedeiros) → review?(mmedeiros)
Comment on attachment 8465321 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22352

looking good! only thing that annoys me should be fixed by Bug 1047283. good work.

PS: it looks like it broke one of integration tests (TEST-UNEXPECTED-FAIL | /builds/slave/test/gaia/apps/calendar/test/marionette/day_view_test.js | day view events longer than 2h click after event end)
Attachment #8465321 - Flags: review?(mmedeiros) → review+

Updated

4 years ago
Flags: in-moztrap?(edchen)

Updated

4 years ago
QA Whiteboard: [COM=Gaia::Calendar][2.1-feature-qa+] → [COM=Gaia::Calendar]
Whiteboard: [tako][p=5] → [tako][p=5][2.1-feature-qa+]
(Assignee)

Comment 24

4 years ago
Hi Miller,

Thanks for the review.
I already fixed the day_view_test.js failure.
For the failures of Gip and Gij[1] are due to Bug 1048953.

[1] https://tbpl.mozilla.org/?rev=cca49194eb6dc78724a4daa3677c5e62ec66d01a&tree=Gaia-Try
(Assignee)

Comment 25

4 years ago
master: db50c8d84054c0286c3ea355feae32ee4a51c82c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Whiteboard: [tako][p=5][2.1-feature-qa+] → [tako][p=7][2.1-feature-qa+]

Updated

4 years ago
Blocks: 1051752
(Assignee)

Updated

4 years ago
Blocks: 1052252
[Environment]
Gaia      c8e93dadeaec6a2617b4db8b7d65ba14aa8db378
Gecko     https://hg.mozilla.org/mozilla-central/rev/c14e5feadc61
BuildID   20140821160203
Version   34.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[Functional testing Result]
4 out of 4 testcases are passed for the 2014-08-21 Flame.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.