Closed Bug 805759 Opened 8 years ago Closed 8 years ago

Relax global search results auto-expand rules

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(firefox19 fixed)

RESOLVED FIXED
Firefox 20
Tracking Status
firefox19 --- fixed

People

(Reporter: vporof, Assigned: vporof)

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(1 file)

In the initial phase of implementing global sources search in the debugger, the decision of having only the first per-file group of matches expanded by default was taken because of performance issues. These could be lifted in case of files with a small set of matches. It would be more convenient to have this rule a bit more relaxed.
FILTER ON PUMPKINS.
Priority: -- → P3
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attached patch v1Splinter Review
Attachment #683566 - Flags: review?(past)
Comment on attachment 683566 [details] [diff] [review]
v1

Review of attachment 683566 [details] [diff] [review]:
-----------------------------------------------------------------

It doesn't feel noticeably slower on my laptop, even for github and gmail, so let's do it. One problem, unrelated to this patch (although it probably makes things slightly worse than they were), is that after searching for "!test", if I try to search for "!click" on a site like gmail, the moment I have left a single character match in the input box ("!t") things slow down to a crawl. We should add a 3-character threshold to make sure the debugger stays responsive at all times.
Attachment #683566 - Flags: review?(past) → review+
(In reply to Panos Astithas [:past] from comment #3)
> Comment on attachment 683566 [details] [diff] [review]
> v1
> 
> Review of attachment 683566 [details] [diff] [review]:
> -----------------------------------------------------------------
> We should add a 3-character threshold to make sure the debugger
> stays responsive at all times.

Agreed.
(In reply to Victor Porof [:vp] from comment #4)
> (In reply to Panos Astithas [:past] from comment #3)
> 
> Agreed.

Or maybe increase the search timeout based on the number of characters? It's currently always set at a comfortable 150ms, but I can't imagine any perceived slowdowns by raising it to 500ms when there are less than 3 characters.
Filed bug 813587.
https://hg.mozilla.org/mozilla-central/rev/3d52cb78cebd
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Comment on attachment 683566 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Searching for a string in all the source files usually shows the results in collapsed menus, which isn't very streamlined.
User impact if declined: Almost none, this patch affects a developer tool, however global search operations are common and this fix fluidizes the experience.
Testing completed (on m-c, etc.): fx-team and m-c
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #683566 - Flags: approval-mozilla-aurora?
Comment on attachment 683566 [details] [diff] [review]
v1

Early enough in the cycle to take a minor feature fix here with little to no risk.
Attachment #683566 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.