If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Handle null and undefined as correct values instead of converted to strings on USSDReceivedEventDict::message

RESOLVED FIXED in Firefox 18

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: willyaranda, Assigned: willyaranda)

Tracking

unspecified
mozilla19
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

Should be:

DOMString ? message = null;

Updated

5 years ago
Assignee: nobody → willyaranda
Blocks: 793178
OS: Mac OS X → All
Hardware: x86 → All
Created attachment 675539 [details] [diff] [review]
Patch

Handle null and undefined as correct values and not convert them to string.
Attachment #675539 - Flags: review?(bugs)

Updated

5 years ago
Attachment #675539 - Flags: review?(bugs) → review+

Updated

5 years ago
Blocks: 794011

Updated

5 years ago
Blocks: 805825

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a38917528484
Comment on attachment 675539 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Followup bug 794011
User impact if declined: We need more checks in our USSD UI (need to check against strings like "undefined" and "null" instead of object null and undefined).
Testing completed (on m-c, etc.): m-i
Risk to taking this patch (and alternatives if risky): None
String or UUID changes made by this patch: None
Attachment #675539 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #675539 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/a38917528484
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
https://hg.mozilla.org/releases/mozilla-aurora/rev/c883d02a0bd9
status-firefox18: --- → fixed
status-firefox19: --- → fixed
You need to log in before you can comment on or make changes to this bug.