Intermittent robocop failures from "ValueError: invalid literal for int() with base 10: '(1'"/'shortMsg=Process'

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
ARM
Android
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=16500022&tree=Mozilla-Inbound
Android no-ionmonkey Tegra 250 mozilla-inbound opt test robocop on 2012-10-26 12:53:39 PDT for push 2373c969584c
slave: tegra-048

22 INFO TEST-PASS | testAllPagesTab | Context menu has Share option - Share
INFO | runtests.py | Received unexpected exception while running application
Traceback (most recent call last):
  File "/builds/tegra-048/test/build/tests/mochitest/runtests.py", line 731, in runTests
    timeout = timeout)
  File "/builds/tegra-048/test/build/tests/mochitest/automation.py", line 1050, in runApp
    status = self.waitForFinish(proc, utilityPath, timeout, maxTime, startTime, debuggerInfo, symbolsPath)
  File "/builds/tegra-048/test/build/tests/mochitest/remoteautomation.py", line 66, in waitForFinish
    status = proc.wait(timeout = maxTime)
  File "/builds/tegra-048/test/build/tests/mochitest/remoteautomation.py", line 202, in wait
    while (self.dm.processExist(self.procName)):
  File "/builds/tegra-048/test/build/tests/mochitest/devicemanager.py", line 175, in processExist
    procList = self.getProcessList()
  File "/builds/tegra-048/test/build/tests/mochitest/devicemanagerSUT.py", line 458, in getProcessList
    processTuples += [[int(pidproc[1]), pidproc[2], int(pidproc[0])]]
ValueError: invalid literal for int() with base 10: '(1'
Looks like this is caused by the change for bug 799507: TypeError exception when running remote reftest.
(Reporter)

Comment 5

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=16740810&tree=Mozilla-Inbound

ValueError: invalid literal for int() with base 10: 'shortMsg=Process'
(Reporter)

Comment 6

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=16743406&tree=Firefox
Summary: Intermittent robocop failures from "ValueError: invalid literal for int() with base 10: '(1'" → Intermittent robocop failures from "ValueError: invalid literal for int() with base 10: '(1'"/'shortMsg=Process'
At first glance, these errors suggest that sutAgent's ps command is sometimes returning "(1" for either the uid or pid -- I don't see how that is possible. Any ideas?
(In reply to Geoff Brown [:gbrown] from comment #8)
> At first glance, these errors suggest that sutAgent's ps command is
> sometimes returning "(1" for either the uid or pid -- I don't see how that
> is possible. Any ideas?

No, it sounds very strange. I think we should have more verbose debugging for this case, so we can see more clearly what's happening here. I was thinking about this on Sunday and have a tentative patch.
Created attachment 678528 [details] [diff] [review]
Be more verbose about problems parsing process list

The one annoying thing about this patch is that we'll still be seeing the same error, but people will probably file it somewhere else because it will have a different error traceback/debugging info. Not sure how to deal with that.
Attachment #678528 - Flags: review?(gbrown)
(Reporter)

Comment 11

6 years ago
That's easy to deal with:

+ print "This is bug 805969, copy-paste the following\n"
Comment on attachment 678528 [details] [diff] [review]
Be more verbose about problems parsing process list

Review of attachment 678528 [details] [diff] [review]:
-----------------------------------------------------------------

I like philor's idea; r+ with the addition of something like that.
Attachment #678528 - Flags: review?(gbrown) → review+
Pushed: https://github.com/mozilla/mozbase/commit/ed7d82c345c166f641e3d67977532b31dc984949

I added the statement "ERROR: Unable to parse process list (bug 805969)" to the output. Hopefully that'll be good enough to link up with this.

I also added a unit test to make sure this was working as expected. :)

Note that we'll need to merge the latest version of mozdevice into m-c to see these changes.
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
These errors are showing up in bug 813858 now.

Updated

6 years ago
Depends on: 814496
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.