Hide Options button for disabled plugins

RESOLVED DUPLICATE of bug 806271

Status

()

RESOLVED DUPLICATE of bug 806271
6 years ago
6 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Currently when you disable a plugin, the Options button is still shown and clicking it does nothing.
Hide the button when the plugin is disabled in order to have the same behavior as extensions.
I don't think they should have the options button at all.
Bug 619652 added that, as it uses inline prefs to add mimetype and library info for plugins. I originally wanted to hide it behind a pref, but got persuaded otherwise. And then forgot to file bug 806271, which would always hide the options button for plugins. Duping to that.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 806271
You need to log in before you can comment on or make changes to this bug.