Closed Bug 806271 Opened 8 years ago Closed 8 years ago

Introduce new settings type, OPTIONS_TYPE_INLINE_INFO

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla22
Tracking Status
firefox19 --- affected
firefox20 --- affected
firefox21 --- affected

People

(Reporter: Unfocused, Assigned: Unfocused)

References

Details

Attachments

(1 file)

In some cases, OPTIONS_TYPE_INLINE is used to display only information - such as plugins (since bug 619652). In these cases, the options button shouldn't really be shown, as there are no options.

So I'd like to introduce a new setting type, OPTIONS_TYPE_INLINE_INFO, which act the same as OPTIONS_TYPE_INLINE except doesn't show the options button.
Duplicate of this bug: 806218
Do you want Firefox 19 with the Options button for plugins in the Add-on manager?
I'm not worried at all about this being shipped unfixed in 19/20. I don't consider it a big issue that needs tracked/fixed right away - its mostly a cosmetic/minor UX issue (and some architectural purity).
Attached patch Patch v1Splinter Review
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Attachment #722607 - Flags: review?(dtownsend+bugmail)
Attachment #722607 - Flags: review?(dtownsend+bugmail) → review+
https://hg.mozilla.org/mozilla-central/rev/82bb694b47f1
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
You need to log in before you can comment on or make changes to this bug.