Closed Bug 806284 Opened 7 years ago Closed 7 years ago

Resizing a window and reverting it moves some text

Categories

(Core :: Layout: Block and Inline, defect)

12 Branch
x86_64
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: m101010a, Assigned: mats)

References

Details

(Keywords: testcase)

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121012050625

Steps to reproduce:

0. Have a window at least 800 pixels wide
1. Visit http://blogs.msdn.com/b/oldnewthing/archive/2012/10/26/10362864.aspx
2. Observe that you can read the entire blockquoted IPv6 address.
3. Resize the window to be 320 pixels wide.
4. Observe that the article content is no longer visible.
5. Revert the window's dimensions.



Actual results:

The blockquoted IPv6 address now hangs off the left side of the blockquote, and is mostly obscured.


Expected results:

The blockquoted IPv6 address should have looked exactly like it did before I resized the window twice.
Blocks: 713856
Component: Untriaged → Layout: Block and Inline
Keywords: regression
OS: Linux → All
Product: Firefox → Core
Version: 16 Branch → 12 Branch
Attached file reduced html
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/8f658d460c3d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20111231 Firefox/12.0a1 ID:20111231031039
Bad:
http://hg.mozilla.org/mozilla-central/rev/d77b056ed4bd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120101 Firefox/12.0a1 ID:20120101031015
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8f658d460c3d&tochange=d77b056ed4bd


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f2610136fb54
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20111230 Firefox/12.0a1 ID:20111230140656
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b3113b7753c1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20111230 Firefox/12.0a1 ID:20111230161855
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f2610136fb54&tochange=b3113b7753c1
Suspected: Bug 713856
Status: UNCONFIRMED → NEW
Ever confirmed: true
Jet, can you please see if someone on the layout team can take this?  Should be reasonably easy to debug, given the small size of the regressing patch.
Assignee: nobody → bugs
+cc: Mats for a look.
This bug also occurs in Firefox 3.6.  The bug was hidden by the erroneous code
added in bug 389321 for Firefox 4 and when that error was corrected in bug 713856
the original bug surfaced.
Assignee: bugs → matspal
No longer blocks: 713856
Keywords: regressiontestcase
Attached patch fixSplinter Review
The problem is that the line isn't reflowed due to a bogus optimization
for eResize reflows in nsBlockFrame::PrepareResizeReflow.  I think we
should just skip that optimization for RTL for now and deal with it
in a separate bug.
https://hg.mozilla.org/mozilla-central/rev/e71b89c8cc84
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Duplicate of this bug: 820278
You need to log in before you can comment on or make changes to this bug.