disable Notification Center support on beta (Firefox 17), it isn't ready

RESOLVED FIXED

Status

()

Toolkit
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Josh Aas, Assigned: Josh Aas)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox17+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 676135 [details] [diff] [review]
fix v1.0

I'm not confident enough in our new Notification Center support to ship it in Firefox 17. We're putting more effort into refining alerts on OS X in upcoming releases. We should disable it on beta.
Attachment #676135 - Flags: review?(doug.turner)

Comment 1

5 years ago
Comment on attachment 676135 [details] [diff] [review]
fix v1.0

Use a pref, maybe?
Attachment #676135 - Flags: review?(doug.turner) → review+
(Assignee)

Comment 2

5 years ago
(In reply to Doug Turner (:dougt) from comment #1)
> Comment on attachment 676135 [details] [diff] [review]
> fix v1.0
> 
> Use a pref, maybe?

I'm not a fan of adding prefs in general, this seems too minor until it actually works well.
(Assignee)

Comment 3

5 years ago
Comment on attachment 676135 [details] [diff] [review]
fix v1.0

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 728106
User impact if declined: OS X 10.8 users will have a poor Notification Center experience
Testing completed (on m-c, etc.): none
Risk to taking this patch (and alternatives if risky): not risky
String or UUID changes made by this patch: none
Attachment #676135 - Flags: approval-mozilla-beta?
status-firefox17: --- → affected
status-firefox18: --- → affected
tracking-firefox17: --- → +
tracking-firefox18: --- → +
Comment on attachment 676135 [details] [diff] [review]
fix v1.0

Approving the disabling for 17 (Beta) and marking tracking/affected for 18 as well so we can check in again in the next Beta cycle to ensure this can stay in.
Attachment #676135 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 5

5 years ago
pushed to mozilla-beta

http://hg.mozilla.org/releases/mozilla-beta/rev/9cfe29fd1612
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox17: affected → fixed
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
Please clear the flags for Firefox 18 on this bug. This bug is only about Firefox 17, bug 805837 is about Firefox 18.
status-firefox18: affected → ---
tracking-firefox18: + → ---
Summary: disable Notification Center support on beta, it isn't ready → disable Notification Center support on beta (Firefox 17), it isn't ready
You need to log in before you can comment on or make changes to this bug.