PBM - add context menu controls

VERIFIED FIXED in Firefox 20

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
10 months ago

People

(Reporter: ibarlow, Assigned: sriram)

Tracking

unspecified
Firefox 20
x86
Mac OS X
Points:
---
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 676590 [details]
Context menu mockup

Allow users to create new private tabs from long pressing a link in web content. A mockup is attached. 

String:
"Open link in new private tab"
(Assignee)

Comment 1

5 years ago
Created attachment 682599 [details] [diff] [review]
Patch (1/2): For webpage.

This adds (copy/pastes) "open in new private tab" option.
Attachment #682599 - Flags: review?(mark.finkle)
(Assignee)

Updated

5 years ago
Attachment #682599 - Attachment description: Patch → Patch (1/2): For webpage.
(Assignee)

Comment 2

5 years ago
Comment on attachment 682599 [details] [diff] [review]
Patch (1/2): For webpage.

That's a wrong patch.
Attachment #682599 - Attachment is obsolete: true
Attachment #682599 - Flags: review?(mark.finkle)
(Assignee)

Comment 3

5 years ago
Created attachment 682604 [details] [diff] [review]
Patch (1/2): For webpage

This adds the "open in new private tab" for links in webpages.
Attachment #682604 - Flags: review?(mark.finkle)
(Assignee)

Comment 4

5 years ago
Created attachment 682606 [details] [diff] [review]
Patch (2/2): For awesomescreen

And some copy paste for awesomescreen.
Attachment #682606 - Flags: review?(mark.finkle)
(Assignee)

Updated

5 years ago
Assignee: nobody → sriram
Attachment #682604 - Flags: review?(mark.finkle) → review+
Attachment #682606 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/87d836ed8e2a
https://hg.mozilla.org/integration/mozilla-inbound/rev/90ef95622f5e
(Assignee)

Updated

5 years ago
Duplicate of this bug: 816996
Blocks: 815897
This landed on inbound a week ago...  What happened after it?!
It was backed out by mfinkle:

https://hg.mozilla.org/integration/mozilla-inbound/rev/6cb490697a27

Dunno if it re-landed after that.
Ugh. I forgot to link it here. Thanks Kats.

Sriram - Can you push this to Try and see what the test failures were about?
Flags: needinfo?(sriram)

Updated

5 years ago
tracking-fennec: --- → ?
status-firefox20: --- → affected
(Assignee)

Comment 10

5 years ago
Done.
https://hg.mozilla.org/integration/mozilla-inbound/rev/d8c8bebfed40
https://hg.mozilla.org/integration/mozilla-inbound/rev/239f4371a480
Flags: needinfo?(sriram)
https://hg.mozilla.org/mozilla-central/rev/d8c8bebfed40
https://hg.mozilla.org/mozilla-central/rev/239f4371a480
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20

Updated

5 years ago
status-firefox20: affected → fixed

Comment 12

5 years ago
The option "Open Link in New Private Tab" is present on latest Nightly: 
Firefox 20.0a1 (2012-12-18)
Device: Galaxy Nexus
OS: Android 4.1.1

Marking bug as VERIFIED FIXED.
Status: RESOLVED → VERIFIED
status-firefox20: fixed → verified

Updated

5 years ago
Flags: in-moztrap?(fennec)

Comment 13

5 years ago
Test cases already added: 
https://moztrap.mozilla.org/manage/cases/_detail/22285/
https://moztrap.mozilla.org/manage/cases/_detail/22286/
Flags: in-moztrap?(fennec) → in-moztrap+
Blocks: 582244
No longer blocks: 815897
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.