After bug 805138 (specifically https://bugzilla.mozilla.org/attachment.cgi?id=675105&action=diff#a/mozilla-tests/b2g_config.py_sec3), we call b2g_emulator_unittest.py with '--test-suite mochitest' rather than '--test-suite mochitests'. We should either update b2g_emulator_unittest.py to take mochitest, or else partially revert that hunk from bug 805138. I would quite like to stick to 'mochitest' throughout, but we use 'reftests' in mozharness - so unless we change that too, we'll be inconsistent. aki any preference?
Component: Mozbase → Release Engineering
Product: Testing → mozilla.org
QA Contact: hskupin
Version: Trunk → other
Example bustage: https://tbpl.mozilla.org/php/getParsedLog.php?id=16588601&tree=Cedar
We're going singular.
Created attachment 676647 [details] [diff] [review] mozharness part v1 Switching all to singular as discussed on IRC. (buildbot part for reftest change coming up)
Attachment #676647 - Flags: review?(aki)
(In reply to Ed Morley [:edmorley UTC+0] from comment #3) > (buildbot part for reftest change coming up) Scratch that, there isn't one to change yet :-)
(In reply to Ed Morley [:edmorley UTC+0] from comment #4) > (In reply to Ed Morley [:edmorley UTC+0] from comment #3) > > (buildbot part for reftest change coming up) > > Scratch that, there isn't one to change yet :-) Correct.
Thank you for the review :-) https://hg.mozilla.org/build/mozharness/rev/9e675c6b8c81
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.