b2g_emulator_unittest.py: error: option --test-suite: invalid choice: 'mochitest' (choose from 'reftests', 'mochitests')

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: emorley, Assigned: emorley)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozharness])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
After bug 805138 (specifically https://bugzilla.mozilla.org/attachment.cgi?id=675105&action=diff#a/mozilla-tests/b2g_config.py_sec3), we call b2g_emulator_unittest.py with '--test-suite mochitest' rather than '--test-suite mochitests'.

We should either update b2g_emulator_unittest.py to take mochitest, or else partially revert that hunk from bug 805138.

I would quite like to stick to 'mochitest' throughout, but we use 'reftests' in mozharness - so unless we change that too, we'll be inconsistent.

aki any preference?
(Assignee)

Updated

6 years ago
Component: Mozbase → Release Engineering
Product: Testing → mozilla.org
QA Contact: hskupin
Whiteboard: [mozharness]
Version: Trunk → other

Comment 2

6 years ago
We're going singular.
(Assignee)

Comment 3

6 years ago
Created attachment 676647 [details] [diff] [review]
mozharness part v1

Switching all to singular as discussed on IRC.

(buildbot part for reftest change coming up)
Attachment #676647 - Flags: review?(aki)
(Assignee)

Comment 4

6 years ago
(In reply to Ed Morley [:edmorley UTC+0] from comment #3)
> (buildbot part for reftest change coming up)

Scratch that, there isn't one to change yet :-)

Comment 5

6 years ago
(In reply to Ed Morley [:edmorley UTC+0] from comment #4)
> (In reply to Ed Morley [:edmorley UTC+0] from comment #3)
> > (buildbot part for reftest change coming up)
> 
> Scratch that, there isn't one to change yet :-)

Correct.

Updated

6 years ago
Duplicate of this bug: 807000

Updated

6 years ago
Attachment #676647 - Flags: review?(aki) → review+
(Assignee)

Comment 7

6 years ago
Thank you for the review :-)

https://hg.mozilla.org/build/mozharness/rev/9e675c6b8c81
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.