Closed Bug 807080 Opened 9 years ago Closed 9 years ago

Some drop down menus appearing as translucent rather than solid with ATI proprietary

Categories

(Core :: Widget: Gtk, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 798157

People

(Reporter: will.j.may, Unassigned)

References

Details

Attachments

(1 file)

I've noticed for a number of weeks that some drop down menus, such as the Bookmarks menu, are appearing as translucent rather than solid. Other examples of this occurring are for Live Bookmarks in the Bookmarks toolbar, Menu options under the 'Nightly' button and the Bookmarks button on the Bookmarks toolbar

I've tried both in safe mode and in a fresh profile.

Steps to reproduce:
* Start Firefox and observe Bookmark menu is solid
* Bookmark a number of items (in my case 5)
* Go to the Bookmark menu

Expected outcome:
Bookmark menu is solid and covers the web page being viewed

Actual outcome:
The web page being viewed bleeds through the menu.
If I hover the mouse over an item in the drop down, it will become solid until the mouse exits the drop down menu.
After installing LXDE on my machine, a key fact might be that I was running Ubuntu 12.04 with Unity.
Component: Theme → Widget: Gtk
Product: Firefox → Core
Similar to bug 798157, but perhaps different.

(In reply to Will May from comment #1)
> After installing LXDE on my machine, a key fact might be that I was running
> Ubuntu 12.04 with Unity.

Did you try without LXDE?

Are you using openbox window manager, or which window manager?

Which graphics driver?

Odd that only the web page content and not the toolbars are bleeding through.
Blocks: 408284
(In reply to Will May from comment #1)
> After installing LXDE on my machine, a key fact might be that I was running
> Ubuntu 12.04 with Unity.

Oh, you installed LXDE but are using Unity, so you wouldn't normally expected LXDE to be involved here?

I guess compiz is the window manger here?
I figured out the regression window before I saw that Karl removed that keyword, so I am posting it in the hopes that it helps.

Last good nightly: 2012-10-03
First bad nightly: 2012-10-04

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=635fcc11d2b1&tochange=4cb8f88213f5
I can also confirm this bug. Menus don't have shadows and they are translucent.

I use Ubuntu 12.04 with Unity and Compiz enabled.

Video card: AMD Radeon HD 6700M Series
Catalyst Driver: 8.96.7-120312a-135598C-ATI
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have a patch for the lack of shadows which I've been meaning to attach, but I'm travelling this week (for the Ubuntu Developer Summit).

I wonder if I can find someone here this week with the proprietary AMD driver who sees the same issue :/
Blocks: 807176
Please let us know if anyone is seeing the same symptoms, but doesn't have the ATI proprietary graphics driver or the compiz window manager.

(In reply to adrian from comment #4)
> Last good nightly: 2012-10-03
> First bad nightly: 2012-10-04
> 
> Pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=635fcc11d2b1&tochange=4cb8f88213f5

Thanks.  That's consistent with bug 408284 being the trigger.
Summary: Some drop down menus appearing as translucent rather than solid → Some drop down menus appearing as translucent rather than solid with compiz and ATI proprietary
This forum post is about an issue on Windows 8, so best track that separately.
This issue showed up on X11 only after platform-specific changes in bug 408284.
I don't know if-given the last comment-this is the right place to point this out,however -in reply to comment 6- I am on Linux with ATI proprietary drivers and have been seing this bug for a while https://bugzilla.mozilla.org/show_bug.cgi?id=805004 first in the UX nightlies and then in Aurora.
Duplicate of this bug: 805004
This seems to be resolved by the workaround in bug 798157.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Summary: Some drop down menus appearing as translucent rather than solid with compiz and ATI proprietary → Some drop down menus appearing as translucent rather than solid with ATI proprietary
Duplicate of bug: 798157
You need to log in before you can comment on or make changes to this bug.