Hook up webpay errors to Sentry

RESOLVED FIXED in 2013-01-17

Status

Marketplace
Payments/Refunds
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kumar, Assigned: kumar)

Tracking

2013-01-17
x86
Mac OS X
Points:
---

Details

(Whiteboard: u=mkt p=1)

Exceptions should go to Sentry http://sentry.dmz.phx1.mozilla.com/
Blocks: 794651
Jason, do you know what we need to add to our settings? https://github.com/mozilla/webpay/blob/master/webpay/settings/base.py The exception emails are in my inbox but still aren't showing up in sentry.
Priority: -- → P1
I added SENTRY_DSN to local.py just now. The stream should come up here: http://sentry.dmz.phx1.mozilla.com/marketplace-dev-webpay/
Thanks Jason! I'll close for now but re-open if I don't see anything next time there's an exception.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
hmm, an exception just came through (I got the email) but it's not showing up in the link above. Any ideas? I gave it a few min, still not there.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: nobody → jthomas
er, needinfo is probably better
Flags: needinfo?(jthomas)
Are we routing Sentry messages through metlog? I am not seeing configuration options for this in webpay/settings/base.py
Flags: needinfo?(jthomas)

Updated

5 years ago
Flags: needinfo?(kumar.mcmillan)
I haven't set up metlog so I'm not sure. Do we need to go through metlog? I guess whatever is easiest. Maybe we can just copy the settings from zamboni for now?
Flags: needinfo?(kumar.mcmillan)
Target Milestone: --- → 2013-01-17
https://github.com/mozilla/webpay/pull/31. @kumar said he would fix up the LOGGING handlers.

Updated

5 years ago
Assignee: jthomas → kumar.mcmillan
Whiteboard: u=mkt p=1
Thanks Jason. I think your pull + this should fix it https://github.com/mozilla/webpay/commit/12dbf2dab15530f5472c12dc96e467b62f14ac09

We'll see...
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 807145
You need to log in before you can comment on or make changes to this bug.