Thunderbird sending wrong images

RESOLVED DUPLICATE of bug 766495

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 766495
5 years ago
2 years ago

People

(Reporter: adds1, Unassigned)

Tracking

16 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

I sent an a mail using "send again", and sent it to a different recipient. 

Thunderbird version 16.0.2, OSX 10.8.2


Actual results:

Thunderbird sent the mail with an image from a different very old mail ( and the other image contained confidential information!).  It is possible, btw. (though not certain) that these images had the same name ("Photo.jpg"). I did not see the wrong image, until after the mail was sent (i.e. in the sent box)


Expected results:

Thunderbird should have resent the mail with the image that was originally in the mail
(Reporter)

Comment 1

5 years ago
I have been able to confirm the bug with another email attempt
Severity: normal → critical
Priority: -- → P1
(Reporter)

Comment 2

5 years ago
The image was an inline image. A number of people hav reported the some issue. See 

https://getsatisfaction.com/mozilla_messaging/topics/thunderbird_embedding_wrong_images_into_emails
(Reporter)

Comment 3

5 years ago
It turns out that both the email I was "sending again" image, and the old email from which the wrong image came, have copies in the "drafts" folder of my local account (non-online).  Oddly both emails were originally sent form a different imap account, and since they were sent, they should have no copies in a drafts folder at all, and certainly not in that of my local account.

Comment 4

5 years ago
I have  had exactly the same thing happen, though I am not certain if all the circumstances were the same. It seems to happen sporadically.
(Reporter)

Updated

5 years ago
Component: FileLink → Message Reader UI
(Reporter)

Updated

5 years ago
Component: Message Reader UI → Message Compose Window
Does this happens when Thunderbird is started with addons disabled ?
Severity: critical → normal
Priority: P1 → --
(Reporter)

Comment 6

5 years ago
I can't reproduce the error any more, since I deleted the old email (for security reasons).

However, may only add-ons are:

Folder Pane Switcher
Folder Pane Tools
Stationary
(Reporter)

Comment 7

5 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #5)
> Does this happens when Thunderbird is started with addons disabled ?

I can't reproduce the error any more, since I deleted the old email (for security reasons).

However, may only add-ons are:

Folder Pane Switcher
Folder Pane Tools
Stationary
(In reply to adds1 from comment #0)
> Actual results:
> Thunderbird sent the mail with an image from a different very old mail
> ( and the other image contained confidential information!).

Same problem as bug 766495?
See bug 766495 comment #14 for procedure to reproduce that bug intentionally.
(Reporter)

Comment 9

5 years ago
(In reply to WADA from comment #8)

> Same problem as bug 766495?
> See bug 766495 comment #14 for procedure to reproduce that bug intentionally.

Yes, this is highly likely. I will try to reproduce that bug as soon as I have time. What was striking about my case is that both the new and the old mail had copies in my _local_ drafts folder, and they were the only mails in that drafts folder. 

This bug is really dangerous: The wrong image sent put me in violation of a contract. I was not able to see that the image was wrong until after it was sent!
Duping to bug 766495 per comment #9.
Please re-open if different problem or particularity in your case will be found.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766495
You need to log in before you can comment on or make changes to this bug.