Closed Bug 807407 Opened 8 years ago Closed 8 years ago

Fix regressions from |Bug 723002 - Determine privacy status from provided nsILoadContext in ContentPrefService|

Categories

(SeaMonkey :: General, defect)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: InvisibleSmiley, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(1 file)

Bug 723002 added a new mandatory privacy context parameter to nsIContentPrefService methods getPref, setPref, hasPref, hasCachedPref, removePref, removeGroupedPrefs, removePrefsByName, getPrefs and getPrefsByName.

Affected SM files (AFAICS):
* common/dataman/dataman.js
* common/dataman/tests/browser_dataman_basics.js
* common/viewZoomOverlay.js
(Sanitizer.jsm is not affected, see bug 713848.)

Original changeset:
http://hg.mozilla.org/mozilla-central/rev/53b97b4ec554

Someone who understands such stuff better than me please kindly take over.
Example error message:

Error: [Exception... "Not enough arguments [nsIContentPrefService.hasCachedPref]"  nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame :: chrome://communicator/content/viewZoomOverlay.js :: FullZoom_onLocationChange :: line 199"  data: no]
Source File: chrome://navigator/content/tabbrowser.xml
Line: 859
[I've seen that the Back button is always disabled in recent builds. Maybe this bug is the cause? If not, we need to look into that separately.]
Attached patch Proposed patchSplinter Review
As far as I can see Data Manager doesn't care about private browsing preferences, so I just pass null as the load context argument.

But because I can, I pass the browser's docShell in when zooming.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #677238 - Flags: review?(philip.chee)
Attachment #677238 - Flags: feedback?(kairo)
Duplicate of this bug: 807507
Comment on attachment 677238 [details] [diff] [review]
Proposed patch

> But because I can, I pass the browser's docShell in when zooming.
I took this patch for a spin. Everything relevant seems to work.
r=me
Attachment #677238 - Flags: review?(philip.chee) → review+
Blocks: 807996
Pushed comm-central changeset 875fbc190af2.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Depends on: 723002
Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0 SeaMonkey/2.16a1 ID:20121104003038 c-c:df4a34dab842 m-c:ab099c9e1a09

Bug 807507 (duped to here) has disappeared from this nightly, and page zoom levels are also persistent again between sessions.
Attachment #677238 - Flags: feedback?(kairo) → feedback+
You need to log in before you can comment on or make changes to this bug.