Appmenu stays open after menu item selection

RESOLVED FIXED in Thunderbird 19.0

Status

Thunderbird
Toolbars and Tabs
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Sean Smith, Assigned: Fallen)

Tracking

({regression})

Trunk
Thunderbird 19.0
x86_64
Windows 7
regression

Thunderbird Tracking Flags

(thunderbird17+ fixed, thunderbird18+ fixed, thunderbird19 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3; Zune 4.7)

Steps to reproduce:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Thunderbird/19.0a1 (01 November 2012 build)

When you open the appmenu, and then choose one of the menu items, the action is completed, and the menu stays open.


Actual results:

I selected the menu item Options... and the options dialog opened.  When I closed the options dialog, the appmenu opened again.

When I selected the New Message menu item, the compose window opened, but the appmenu remained open.


Expected results:

The appmenu should not reopen after dismissing the options dialog or after choosing any other menu item.
This might be by design?

Comment 2

5 years ago
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/9d285bedbc1f
http://hg.mozilla.org/comm-central/rev/2aee2804b79b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Thunderbird/18.0a1 ID:20120923030232
Bad:
http://hg.mozilla.org/mozilla-central/rev/faa753e8601f
http://hg.mozilla.org/comm-central/rev/987cb8d53150
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Thunderbird/18.0a1 ID:20120924043558
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9d285bedbc1f&tochange=faa753e8601f
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=2aee2804b79b&tochange=987cb8d53150

Suspected : Bug 785692
Blocks: 785692
Status: UNCONFIRMED → NEW
tracking-thunderbird18: --- → ?
tracking-thunderbird19: --- → ?
Ever confirmed: true
Keywords: regression

Comment 3

5 years ago
This also affected in 17beta and maybe affected 17esr.

http://hg.mozilla.org/releases/mozilla-beta/rev/2584cac54ea7
http://hg.mozilla.org/releases/comm-beta/rev/f5fbdcff1f78
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Thunderbird/17.0 ID:20121030125442
tracking-thunderbird17: --- → ?
Just reproduced this on Windows 7. On OSX and Ubuntu, I notice that after I click, the menu respawns before hiding - so I think it's a race.

STR:

1) On a Windows machine, click on the AppMenu, and choose "Options"
2) When the Options dialog appears, click "Cancel" to close it.

What happens?

The AppMenu respawns.

What's expected?

The AppMenu should not respawn.
QA Contact: mconley
Hm - this seems to happen on each of our split menus - so I see it on Print, Message Filters, Find, and New Message.
I think I've traced this to our appmenu-vertical binding here:

http://mxr.mozilla.org/comm-central/source/mail/base/content/mailWidgets.xml#2832

Since the menupopup exists *within* the button, I think the click handler is called both when we first open the menu, and (it seems) any time we click on a splitmenu immediately beneath the menupopup.

Philipp - I do believe you introduced this binding. Any ideas what we can do about this?
Flags: needinfo?(philipp)
(Assignee)

Comment 7

5 years ago
Created attachment 677822 [details] [diff] [review]
Fix - v1

This should take care, tested on Mac.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #677822 - Flags: review?(mconley)
Flags: needinfo?(philipp)
Comment on attachment 677822 [details] [diff] [review]
Fix - v1

Review of attachment 677822 [details] [diff] [review]:
-----------------------------------------------------------------

Yep - looks great! Thanks Phillip!
Attachment #677822 - Flags: review?(mconley)
Attachment #677822 - Flags: review+
Attachment #677822 - Flags: approval-comm-beta?
Attachment #677822 - Flags: approval-comm-aurora?
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/comm-central/rev/c42bb5c1cfd0
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-thunderbird19: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 19.0
(Reporter)

Comment 10

5 years ago
Confirming as fixed for me.  Thanks!

Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/19.0 Thunderbird/19.0a1 (03 November 2012 build)
Attachment #677822 - Flags: approval-comm-beta?
Attachment #677822 - Flags: approval-comm-beta+
Attachment #677822 - Flags: approval-comm-aurora?
Attachment #677822 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/6ffaea334b4f
https://hg.mozilla.org/releases/comm-beta/rev/53faaeb4d17e
status-thunderbird17: --- → fixed
status-thunderbird18: --- → fixed
tracking-thunderbird17: ? → +
tracking-thunderbird18: ? → +
tracking-thunderbird19: ? → ---
You need to log in before you can comment on or make changes to this bug.