"Reddit Enhancement Suite" stops working in Nightly19.0a1

RESOLVED INVALID

Status

()

Core
JavaScript Engine
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({addon-compat, regression})

19 Branch
x86
Windows 7
addon-compat, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/5bd5bb168eb1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121101030705

Step To Reproduce:
1. Install "Reddit Enhancement Suite" extensions http://redditenhancementsuite.com/download-firefox.html
2. Open http://www.reddit.com/r/funny/ (for example)
3. Scroll down (for example)

Actual Results:
  Auto-pager does not work

Expected Results:
  Auto-pager should work

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/3a7226d6429b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121029070837
Bad:
http://hg.mozilla.org/mozilla-central/rev/f677f91c89c0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121029134937
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3a7226d6429b&tochange=f677f91c89c0

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/461978f9a844
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121029083938
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/8a2b481bb4d1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121029085538
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=461978f9a844&tochange=8a2b481bb4d1

Triggered by: Bug 803068
(Reporter)

Updated

6 years ago
tracking-firefox19: --- → ?
Keywords: addon-compat

Comment 1

6 years ago
The latest version of RES (4.1.4) can be found at https://addons.mozilla.org/en-US/firefox/addon/reddit-enhancement-suite/

Comment 2

6 years ago
dupe of bug 807623?
(Reporter)

Comment 3

6 years ago
"Reddit Enhancement Suite" uses jquery-1.6.4  . 
If changed the jquery-1.6.4 to the newest 1.8.2, It works.

So, this is RES' problem.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
tracking-firefox19: ? → ---
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.