Closed Bug 807981 Opened 12 years ago Closed 12 years ago

Facebook new friend request notification link is not opened in new tab

Categories

(Firefox Graveyard :: SocialAPI: Providers, defect)

17 Branch
defect
Not set
normal

Tracking

(firefox17 verified)

VERIFIED FIXED
Tracking Status
firefox17 --- verified

People

(Reporter: virgil.dicu, Unassigned)

Details

Attachments

(2 files)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 beta 4
Build ID: 20121031065642

Steps to reproduce:
1. Launch Firefox and log into your Facebook account
2. Activate Messenger for Firefox from the Facebook activation page -> Click on the Turn On button http://www.facebook.com/about/messenger-for-firefox
3. Have a pending friend request notification
4. Click on the Friend Request button
5. Click on the friend's name.

Expected result:
When clicking the friend's name, a new tab should open with the facebook friend's profile page.

Actual result:
A small pop-up appears under Friend Request button.
Click again the Friend Request button, the pop-up disappears.
Click again the Friend Request button, the pop-up is shown on the same width but the height is now occupying the whole page.
Component: SocialAPI → SocialAPI: Providers
Summary: Social API Facebook new friend request notification is not opened in new tab → Facebook new friend request notification link is not opened in new tab
I believe we had a dupe of this somewhere. I can't find it in Bugzilla so maybe it's in Asana. CCing Shane in case he knows.
Yes, it's a known issue. Facebook needs to adjust all of its links, which is a game of whack-a-mole.
We just whacked these at least so this should be fixed by next week's Tuesday push.
Virgil, please verify if this is fixed on November 14.
Keywords: verifyme
QA Contact: virgil.dicu
Verified on
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 Beta 6
Build ID: 20121113065533

Facebook friend request works fine now. I clicked on friend's name and it opened his profile in new tab as expected. Also confirmation of friendship acted normal in the pop-up, a "request confirmed" message appears. After this the request disappears.
Marking this fixed as per comment 4.
Status: NEW → RESOLVED
Closed: 12 years ago
Keywords: verifyme
Resolution: --- → FIXED
Marking this verified based on comment 6.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: