Initial zoom level of loaded page is not mobile friendly

RESOLVED DUPLICATE of bug 798245

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 798245
5 years ago
5 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

({b2g-testdriver, unagi})

unspecified
x86
Mac OS X
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: Steps to reproduce in comment 7)

Attachments

(5 attachments)

(Reporter)

Description

5 years ago
Created attachment 677779 [details]
Screen shot of the bug

Build 2012-11-01

See attachment.

To reproduce:

1) Open http://news.ycombinator.com
2) Zoom to make it readable
2) Tap "Google Android Director on Nexus Strategy" - http://bits.blogs.nytimes.com/2012/11/02/android-nexus-strategy/
Ben, thoughts on this one?
Flags: needinfo?(ben)
I'm not sure what the expectation is here, but the screenshot shows a blurry image when zoomed in which is odd. If there is a bug it would seem like a viewport or async pan and zoom issue in Gecko.
Component: Gaia → General
Flags: needinfo?(ben)
Stefan, I'm very confused what this bug is about.

The summary of the bug is that the zoom level is wrong when you are loading a page. However the steps to reproduce mentions that are are actually zooming in as part of the steps. And the screenshot seems to be complaining about the fact that things are blurry rather than at the wrong zoom level.

Is the problem you are seeing with http://news.ycombinator.com or with http://bits.blogs.nytimes.com/2012/11/02/android-nexus-strategy/?

Are the steps mentioned in comment 0 all needed, or does loading http://bits.blogs.nytimes.com/2012/11/02/android-nexus-strategy/ directly reproduce the problem?

Is the problem that something is zoomed in too much when the page is loaded, or that something is zoomed out when the page is loaded? Or is the problem that text is blurry when zoomed to the desired level?
Flags: needinfo?(sarentz)
(Reporter)

Comment 4

5 years ago
I cannot reproduce this anymore. I thought the real problem was that

a) paged would inherit the zoom level of the previous page

or

b) newly loaded pages do not zoom (out) to fit on the screen

I reported something similar for Fennec a while ago:

https://bugzilla.mozilla.org/show_bug.cgi?id=778583

Anyway. With the latest build i've opened a good number of pages linked from hackernews and they all open correctly zoomed to fit.

So invalid?
Flags: needinfo?(sarentz)
(Reporter)

Comment 5

5 years ago
Oh I also tested with http://bits.blogs.nytimes.com/2012/11/02/android-nexus-strategy/ and that site now also correctly opens zoomed to fit.
Ah! Now I understand the problem you filed the bug on. Having "expected results" and "actual results" in the initial description would have helped.

Don't hesitate to reopen or file a new bug if you see the problem again, especially if you have steps to reproduce.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
blocking-basecamp: ? → ---
(Reporter)

Comment 7

5 years ago
I would like to reopen this bug because I don't think the current behavious is correct.

This is on the 2012-11-28 build:

STR:

1) Go to news.ycombinator.com
2) Zoom the page so that you can read the links, tap a link

Expected:

The site that we just opened should open zoomed to fit so that you can see the whole page and go from there.

Actual:

The site the we just opened is loaded and has the same zoom level as the previous page. This is inconvenient. In case of opening something from a zoomed Hackernews page, the new site just shows a hugely zoomed top left corner for example.

I can provide screenshots to clarify if needed.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

5 years ago
Correction: My report was for the 2012-11-27 build.
(Reporter)

Comment 9

5 years ago
Created attachment 686134 [details]
Example 1
(Reporter)

Comment 10

5 years ago
Created attachment 686135 [details]
Example 1 Manually Zoomed to Fit
(Reporter)

Comment 11

5 years ago
Created attachment 686136 [details]
Example 2
(Reporter)

Comment 12

5 years ago
Created attachment 686137 [details]
Example 2 Manually Zoomed to Fit
(Reporter)

Comment 13

5 years ago
Added some examples of how the page actually opens on the device and how it should have opened.
Over to gaia for triage. I'm not convinced that this is a blocker. But I agree that it does sound like something that we'd ideally fix.
blocking-basecamp: --- → ?
Component: General → Gaia
Whiteboard: Steps to reproduce in comment 7
This is just a bug in apzc.  The fix in bug 798245 should take care of this.
Depends on: 798245
Duping to bug 798245 and setting that as b-b+ given comment 15.
Status: REOPENED → RESOLVED
blocking-basecamp: ? → -
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 798245
You need to log in before you can comment on or make changes to this bug.