Closed Bug 778583 Opened 8 years ago Closed 8 years ago

Pages that are >980px wide are not zoomed out as far as possible on initial load

Categories

(Firefox for Android :: Toolbar, defect)

17 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 778580

People

(Reporter: st3fan, Unassigned)

References

Details

Attachments

(2 files)

Open for example http://arstechnica.com/apple/2012/07/os-x-10-8/5/

Page opens with a weird zoom factor. Left side of the page is clipped.

On the above page it does not matter so much since the article text is still visible but sometimes the zooming clips the actual content.

Screenshots attached of both Fennec and Chrome for the same page.
Attached image Screenshot of Fennec
Attached image Screenshot of Chrome
Component: General → Graphics, Panning and Zooming
OS: Mac OS X → Android
Hardware: x86 → ARM
I'm getting this as well on Nexus S running jelly bean. Non mobile sites appear to have a large image of the entire page loaded onto the top left of the page.
Thinking this is also related to the bugs posted in bug 778580.
(In reply to Stefan Arentz [:st3fan] from comment #0)
> Open for example http://arstechnica.com/apple/2012/07/os-x-10-8/5/
> 
> Page opens with a weird zoom factor. Left side of the page is clipped.

By default, Fennec sets the initial viewport size and scale so that the page is laid-out and clipped the same as in a desktop browser with a 980px-wide window.  Most pages handle this window size gracefully, but a few do not.

We could make Fennec scale >980px pages to fit the document to the screen width (instead of fitting the viewport to the screen width, as it does now).  That's what we did until bug 681995 implemented the current behavior.  But that caused some pages to be zoomed out much more than desirable.  So it's a trade-off...

(In reply to Demetrius Schwab from comment #3)
> I'm getting this as well on Nexus S running jelly bean. Non mobile sites
> appear to have a large image of the entire page loaded onto the top left of
> the page.

I think this is a separate bug (probably related to bug 778580, as Aaron says).
Blocks: 681995
Summary: Pages open with a strange zoom factor → Pages that are 980px wide are not zoomed out as far as possible on initial load
Summary: Pages that are 980px wide are not zoomed out as far as possible on initial load → Pages that are >980px wide are not zoomed out as far as possible on initial load
This issue is reproducible even on mobile pages which it supposed to be <980px
I cannot reproduce this bug anymore on the latest Nightly.

--
Firefox 17.0a1 (2012-07-31)
Device: Galaxy R
OS: Android 2.3.4
Confirmed. Works well as of July 31st. I like this new behaviour.
Okay, then I must have misunderstood, and this was indeed fixed by the backouts for bug 778580.  Sorry for the confusion!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 778580
You need to log in before you can comment on or make changes to this bug.