Closed Bug 808175 Opened 7 years ago Closed 7 years ago

OfflineCacheUpdateChild.h:78:10: warning: 'mozilla::docshell::OfflineCacheUpdateChild::mInBrowser' will be initialized after ... mAppID' [-Wreorder]

Categories

(Core :: Networking: Cache, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 808036

People

(Reporter: dholbert, Assigned: dholbert)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

New build warning:
{
In file included from uriloader/prefetch/OfflineCacheUpdateChild.cpp:6:0:

uriloader/prefetch/OfflineCacheUpdateChild.h:78:10: warning: 'mozilla::docshell::OfflineCacheUpdateChild::mInBrowser' will be initialized after [-Wreorder]

uriloader/prefetch/OfflineCacheUpdateChild.h:77:14: warning:   'uint32_t mozilla::docshell::OfflineCacheUpdateChild::mAppID' [-Wreorder]

uriloader/prefetch/OfflineCacheUpdateChild.cpp:81:1: warning:   when initialized here [-Wreorder]
}

Bug 794663 added these variables to the constructor init list in the reverse order w.r.t. their declaration order in the class.

 Init list:
   http://hg.mozilla.org/mozilla-central/rev/113d5069e67e#l1.12
 Class definition:
   http://hg.mozilla.org/mozilla-central/rev/113d5069e67e#l2.14
Attached patch fixSplinter Review
Attachment #677873 - Flags: review?(jduell.mcbugs)
oops, Ms2ger already filed this
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 808036
Attachment #677873 - Flags: review?(jduell.mcbugs)
You need to log in before you can comment on or make changes to this bug.