Closed Bug 808318 Opened 7 years ago Closed 7 years ago

"ASSERTION: Children must have same reference frame" with SVG display lists disabled for painting

Categories

(Core :: SVG, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jruderman, Assigned: jwatt)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(2 files)

Attached image testcase
With:
  user_pref("svg.display-lists.painting.enabled", false);

The testcase triggers:

###!!! ASSERTION: Children must have same reference frame: 'mList.IsEmpty() || !ReferenceFrame() || !mList.GetBottom()->ReferenceFrame() || mList.GetBottom()->ReferenceFrame() == ReferenceFrame()', file layout/base/nsDisplayList.h, line 2083
Attached file stack
This seems to be WFM now, Jesse.
https://hg.mozilla.org/mozilla-central/rev/3cd792b48fda
Assignee: nobody → jwatt
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Not WFM.  Still reproduces as reported.  Note the pref!
Status: RESOLVED → REOPENED
Flags: in-testsuite+
Resolution: WORKSFORME → ---
Target Milestone: mozilla20 → ---
(In reply to Jesse Ruderman from comment #5)
> Note the pref!

(If/when this is actually fixed or WFM, we should add another copy of this bug's line in crashtests.list w/ a "pref()" annotation)
Flags: in-testsuite?
Actually the svg display list prefs aren't supported any more, so closing as wontfix.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WONTFIX
I filed bug 829802 for removing the pref.
You need to log in before you can comment on or make changes to this bug.