Closed Bug 808377 Opened 7 years ago Closed 7 years ago

Social menuitem not hidden in view > sidebar with social disabled

Categories

(Firefox Graveyard :: SocialAPI, defect)

17 Branch
defect
Not set

Tracking

(firefox17+ verified, firefox18+ verified, firefox19 unaffected)

VERIFIED FIXED
Tracking Status
firefox17 + verified
firefox18 + verified
firefox19 --- unaffected

People

(Reporter: mcdavis941.bugs, Assigned: markh)

References

Details

Attachments

(2 files)

I might be looking at this wrong, but Bug 804258 makes it seem like the intention was for the "Facebook Messenger" menuitem to be hidden under the View > Sidebar menu unless social is enabled.  It's still visible after deactivating social -- see the screenshot.

This is with Fx17 beta 4.

Mozilla/5.0 (Windows NT 6.0; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

Bug 804442 , Bug 772808 and Bug 805653 seem related, but those aren't in mozilla-beta, so I'll just report this anyway.
Attached image screenshot
OS: Windows Vista → All
Hardware: x86_64 → All
It looks like bug 804258 had the wrong attachment checked in on beta and aurora - it was missing the explicit update of the menu_socialSidebar item.  This patch re-adds that update.
Attachment #678179 - Flags: review?(gavin.sharp)
Comment on attachment 678179 [details] [diff] [review]
update view->sidebar menu

ugh, sorry I messed up that landing :(
Attachment #678179 - Flags: review?(gavin.sharp)
Attachment #678179 - Flags: review+
Attachment #678179 - Flags: approval-mozilla-beta+
Attachment #678179 - Flags: approval-mozilla-aurora+
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
https://hg.mozilla.org/releases/mozilla-aurora/rev/66bada6ea6b2
https://hg.mozilla.org/releases/mozilla-beta/rev/518b70ac56cc

This bug does not affect Firefox 19 because it was fixed by Bug 772808, which could not be uplifted to aurora/beta

(I'm marking this one as depending in 772808 in case 772808 gets backed out; we'll know we have to implement this on trunk as well)
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Depends on: 772808
Resolution: --- → FIXED
Thanks a lot for reporting this, mcdavis - very timely!
This issue seems to be fixed. I've tested it on the latest beta, Firefox 17 beta 6, on 3 different platforms: Windows 7 64-bit, Mac 10.8 and Ubuntu 12.04 32-bit.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121113065533

User Agent:  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121113065533

User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121113065533
Thanks Manuela. When you get a chance, can you please check Aurora 18.0a2 as well? Thanks.
Keywords: verifyme
Works as expected also on Aurora 18.0a2.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121115042012

User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121115042012

User Agent:  Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121115042012
Much appreciated. Thank you Manuela.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.