Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Hide Virtual Keyboard when bookmarks list is opened

VERIFIED FIXED in Firefox 20

Status

()

Firefox for Android
Awesomescreen
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: wolpi.dev, Assigned: wesj)

Tracking

16 Branch
Firefox 20
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox19- affected, firefox20 verified, firefox21 verified, relnote-firefox 20+, fennec20+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 678128 [details]
screenshot_bookmarks_keyboard.png

User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

- open firefox
- rotate device to landscape mode
- tap url bar to open awesomescreen
- tap bookmarks


Actual results:

- Virtual Keyboard is shown, so I cannot see my bookmarks. Have to hide Virtual Keyboard myself.


Expected results:

- Virtual Keyboard should be hidden so that I can see my bookmarks
(Reporter)

Comment 1

5 years ago
Device: HTC Sensation
Android Version: 4.0.3
Ideally the URL bar should lose focus. It seems to do so when you switch between Top Sites and Bookmarks back and forth, so I wonder why the first time the focus is kept.

CC :ibarlow, :mfinkle for input here
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → Android
Hardware: x86 → ARM
(Assignee)

Comment 3

5 years ago
This used to work. Its a regression.
Keywords: regressionwindow-wanted
Lucas?
tracking-fennec: --- → ?
Keywords: regression
Yeah, some (recent?) change broke focus handling in Awesome Screen. It would probably help to know when this happened.
(Reporter)

Comment 6

5 years ago
I noticed it when I upgraded form FF15 to 16 via google play.
Assignee: nobody → wjohnston
tracking-fennec: ? → 18+
Possible dupe of 770170?
Looks like it
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 770170
Can someone carry over the tracking 18+ to bug 770170.
Keywords: regressionwindow-wanted
(Assignee)

Comment 10

5 years ago
Created attachment 682180 [details] [diff] [review]
Patch

This fixes two bugs (switching screens and scrolling the list).
Attachment #682180 - Flags: review?(bnicholson)
Comment on attachment 682180 [details] [diff] [review]
Patch

>-                if (event.getAction() == MotionEvent.ACTION_DOWN)
>+                if ((event.getAction() & MotionEvent.ACTION_MASK) == MotionEvent.ACTION_DOWN)

It'd probably be cleaner to use MotionEvent.getActionMasked() to apply the action mask.
Attachment #682180 - Flags: review?(bnicholson) → review+
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Duplicate of this bug: 770170
tracking-fennec: 18+ → 20+
(Assignee)

Comment 13

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f48d082d7d0
(Assignee)

Comment 14

5 years ago
I'm hoping this was the cause of robocop failures. backed out:

https://hg.mozilla.org/integration/mozilla-inbound/rev/b4bfe7e32928
Keywords: regression

Updated

5 years ago
Duplicate of this bug: 813018
Was it?
Also, did you intentionally omit the change suggested in comment 11?
(Assignee)

Updated

5 years ago
tracking-firefox19: --- → ?
tracking-firefox19: ? → +
(Assignee)

Comment 18

5 years ago
Created attachment 691097 [details] [diff] [review]
Patch

Fix the test failures. I apparently added tests to make sure we didn't fix this at one point.

I also put in a fix for finding the bookmarks button in the menu on ICS+ devices (where it no longer has a text label so clickText("Bookmark") doesn't work anymore. Maybe we should move that somewhere more general?
Attachment #691097 - Flags: review?(gbrown)
(Assignee)

Comment 19

5 years ago
Looks mostly good on try. Waiting for a retrigger.
(Assignee)

Comment 20

5 years ago
https://tbpl.mozilla.org/?tree=Try&rev=a64d770a8e9e
Comment on attachment 691097 [details] [diff] [review]
Patch

I may have added that vkb code when the tests started failing -- oops! Glad we are on the same page now. 

Try run looks solid.
Attachment #691097 - Flags: review?(gbrown) → review+
(Assignee)

Comment 22

5 years ago
Pushed again. Fingers crossed. I'll request Aurora approval once they're green.
https://hg.mozilla.org/integration/mozilla-inbound/rev/8a94633be564
https://hg.mozilla.org/integration/mozilla-inbound/rev/3eafe802b846
(Assignee)

Comment 23

5 years ago
Comment on attachment 682180 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 759041
User impact if declined: impossible to hide the keyboard and see the whole awesomescreen
Testing completed (on m-c, etc.): Landed on mc 12-11
Risk to taking this patch (and alternatives if risky): This is pretty low risk. Hooking up some function I accidentally unhooked.
String or UUID changes made by this patch:  None.
Attachment #682180 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 24

5 years ago
Comment on attachment 691097 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Same
User impact if declined: Non. Fixes tests
Testing completed (on m-c, etc.): Landed on mc 12-11. Tests now pass
Risk to taking this patch (and alternatives if risky): Low risk. Test only.
String or UUID changes made by this patch: none.
Attachment #691097 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8a94633be564
https://hg.mozilla.org/mozilla-central/rev/3eafe802b846
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20

Updated

5 years ago
Attachment #682180 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Attachment #691097 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 26

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/7ec301dff48c
https://hg.mozilla.org/releases/mozilla-aurora/rev/3cdce9376da6
(reminder to set fixed on the channel)
status-firefox19: --- → fixed
status-firefox20: --- → fixed
(In reply to Wesley Johnston (:wesj) from comment #26)
> https://hg.mozilla.org/releases/mozilla-aurora/rev/7ec301dff48c
> https://hg.mozilla.org/releases/mozilla-aurora/rev/3cdce9376da6

This broke robocop on aurora:
https://tbpl.mozilla.org/?tree=Mozilla-Aurora&rev=3cdce9376da6

Aurora backout:
https://hg.mozilla.org/releases/mozilla-aurora/rev/900485806593
status-firefox19: fixed → affected
Wesley - can you take another look at landing this on Aurora?
(Assignee)

Comment 30

5 years ago
Missed one test change when unbitrotting last time. Pushed again:

https://hg.mozilla.org/releases/mozilla-aurora/rev/5d9eae38d5eb
https://hg.mozilla.org/releases/mozilla-aurora/rev/0bb84e1c8ad6
Still broke robocop. Also, remember that Aurora isn't inbound. You are expected to watch your pushes and back them out if they break things.
https://hg.mozilla.org/releases/mozilla-aurora/rev/c946b3643904

https://tbpl.mozilla.org/php/getParsedLog.php?id=18061313&tree=Mozilla-Aurora

0 INFO SimpleTest START
1 INFO TEST-START | testBookmark
2 INFO TEST-PASS | testBookmark | checking that bookmarks list exists - bookmarks list exists
3 INFO TEST-PASS | testBookmark | bookmarks list has 4 children (the default bookmarks) - 4 should equal 4
Exception caught during test!
java.lang.NullPointerException
	at org.mozilla.fennec_aurora.tests.testBookmark.runAwesomeScreenTest(testBookmark.java:106)
	at org.mozilla.fennec_aurora.tests.testBookmark.testBookmark(testBookmark.java:55)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.fennec_aurora.tests.BaseTest.runTest(BaseTest.java:120)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
4 INFO TEST-UNEXPECTED-FAIL | testBookmark | Exception caught - java.lang.NullPointerException
5 INFO TEST-END | testBookmark | finished in 42833ms
6 INFO TEST-START | Shutdown
7 INFO Passed: 2
8 INFO Failed: 1
9 INFO Todo: 0
10 INFO SimpleTest FINISHED
Attachment #682180 - Attachment is obsolete: true
Attachment #682180 - Flags: approval-mozilla-aurora+
Attachment #691097 - Flags: approval-mozilla-aurora+
I have a fix for the testBookmark problem coming soon in bug 769919.
(Assignee)

Comment 33

5 years ago
This slipped my mind. I fixed up geoff's patch and pushed it with these to try (based on top of beta):
https://tbpl.mozilla.org/?tree=Try&rev=c707a67cf7e6
Virtual keyboard is hidden when accessing the Bookmarks tab either by tapping on the Tab title or by swipe on Aurora 20.0a2 2013-01-10 on the HTC Desire Z (Android 2.3.3) marking as verified on FF 20 but leaving th bug open for the Robocop test fixes
status-firefox20: fixed → verified
Given comment 6, we won't track for release. Feel free to nominate for uplift if you believe the fix is low risk.
tracking-firefox19: + → -
This issue doesn't occur anymore on the latest Nightly. Closing bug as verified fixed on:

Firefox for Android
Version: 21.0a1 (2013-01-29)
Device: Galaxy R
OS: Android 2.3.4
Status: RESOLVED → VERIFIED
status-firefox21: --- → verified

Updated

5 years ago
relnote-firefox: --- → ?
relnote-firefox: ? → 20+
You need to log in before you can comment on or make changes to this bug.