Moving another window over mozilla leaves blank regions

VERIFIED FIXED in mozilla0.9.1

Status

()

Core
Layout: View Rendering
--
critical
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Kevin McCluskey (gone), Assigned: Kevin McCluskey (gone))

Tracking

({regression, top100})

Trunk
mozilla0.9.1
x86
Windows NT
regression, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
 
(Assignee)

Comment 1

17 years ago
Rapidly move a command prompt window over Mozilla. Notice the chrome does not
refresh properly when the exposed area is repainted
Severity: normal → critical
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 2

17 years ago
The general refresh problem (Not refreshing the newly exposed area when moving a
window over the top of mozilla) was created by the checkin for bug 75591
Keywords: mostfreq, mozilla0.9.1, nsbeta1, regression, top100
(Assignee)

Comment 3

17 years ago
The general refresh problem on WIN32 created by the checkin for bug 75591 was 
caused by failing to return a status which tells the toolkit the paint was 
consumed, don't do default processing:

the following patch fixes the general refresh problem:

Index: nsViewManager.cpp
===================================================================
RCS file: /cvsroot/mozilla/view/src/nsViewManager.cpp,v
retrieving revision 3.187
diff -u -r3.187 nsViewManager.cpp
--- nsViewManager.cpp   2001/04/24 01:01:14     3.187
+++ nsViewManager.cpp   2001/05/15 01:51:52
@@ -1966,6 +1966,7 @@
                                                                                        
}
                                                                                
}
                                                                        }
+                         *aStatus = nsEventStatus_eConsumeNoDefault;
                                                        }
 
                                break;
(Assignee)

Updated

17 years ago
Whiteboard: Waiting for review/super-review
sr=roc+moz

Comment 5

17 years ago
r=dcone
(Assignee)

Comment 6

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: Waiting for review/super-review

Updated

17 years ago
Blocks: 79543

Comment 7

17 years ago
Marking verified in the May 22nd build.
Status: RESOLVED → VERIFIED

Comment 8

16 years ago
*** Bug 83142 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.