All users were logged out of Bugzilla on October 13th, 2018

Cyrus IMAP: Unable to subscribe to folders.

VERIFIED DUPLICATE of bug 55774

Status

--
major
VERIFIED DUPLICATE of bug 55774
18 years ago
10 years ago

People

(Reporter: oliver, Assigned: mscott)

Tracking

({imap-interop})

Trunk
x86
Linux
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Platform: Linux, Cyrus IMAPD 2.0.12, Mozilla 0.9

I create folders inside cyradm (the Cyrus Admin cmd line tool) and give the 
users write permissions on said folder.  In Moz Mail I attempt to "subscribe" 
to the folder using the subscribe UI.  However it fails with a "Mailbox does 
not exist" error.  Outlook express on the otherhand subscribes to the folder 
just fine.

Comment 1

18 years ago
Reporter what is the name of the folder? Does it have any special characters in
it? if so this is probably a dupe of bug 77310

Comment 2

18 years ago
I'm seeing this as well with Debian Linux, build 2001061309. I'll check it on
0.9.1 on Windows as soon as I can. It's not a dupe of bug 77310, no special
chars are involved.

Updated

18 years ago
QA Contact: esther → huang

Comment 3

18 years ago
Marking NEW based on confirmation.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: interop

Comment 4

18 years ago
This works for me on folders which I create with Mozilla. I do not have admin
access, so I cannot verify for folders created by Cyrus.

Comment 5

18 years ago
I have the same problem with CyrusIMAP 2.0.14 and Mozilla 0.9.2 on Windows200.
I tried to look at the Cyrus logs and found that mozilla tries to subsribe to 
folder :
 subscribe "INBOX/subfolder" 
while other programs:
 subscribe "INBOX.subfolder" 
.
I think the problem is that mozilla uses "/" instead of a ".".

Comment 6

17 years ago
this appears to be a duplicate of bug 55774, which has been fixed.

i'll test a recent nightly against cyrus.andrew.cmu.edu, running Cyrus 2.0.16.

Comment 7

17 years ago
i've confirmed i can subscribe to folders on cyrus.andrew.cmu.edu.
i believe this bug is fixed.

Comment 8

17 years ago
Yes. This was fix from bug 55774

*** This bug has been marked as a duplicate of 55774 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.