PAC: Console shows "PAC:Loading PAC from <URL>" everytime

RESOLVED FIXED

Status

()

Core
Networking
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: benc@chuang.net, Assigned: serge (gone))

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
STEPS:

After configuring PAC, then turning it off, I still see:

PAC:Loading PAC from <URL> in Console everytime I start (somewhere after
selecting a profile).

Comment 1

17 years ago
fixing summary
Summary: PAC: Console shows "PAC:Loading PAC fromPAC: Console shows "PAC:Loading PAC from <URL>" everytime → PAC: Console shows "PAC:Loading PAC from <URL>" everytime

Comment 2

17 years ago
-->PAC bugs to Jussi
Assignee: neeti → jpm

Comment 3

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc
(Assignee)

Comment 4

17 years ago
this is a debug output, the next  patch does comment it out:
===================================================================
RCS file: /cvsroot/mozilla/netwerk/base/src/nsProxyAutoConfig.js,v
retrieving revision 1.9
diff -u -r1.9 nsProxyAutoConfig.js
--- nsProxyAutoConfig.js        2001/04/26 14:06:22     1.9
+++ nsProxyAutoConfig.js        2001/05/30 01:24:53
@@ -70,7 +70,7 @@
         var uri = url.QueryInterface(Components.interfaces.nsIURI);
         // Call the original function-
         var proxy = LocalFindProxyForURL(uri.spec, uri.host);
-        debug("Proxy = " + proxy);
+//        debug("Proxy = " + proxy);
         if (proxy == "DIRECT") {
             host.value = null;
             type.value = "direct";
@@ -89,7 +89,7 @@
     },

     LoadPACFromURL: function(uri, ioService) {
-        debug("Loading PAC from " + uri.spec);
+//       debug("Loading PAC from " + uri.spec);
         this.done = false;
         var channel = ioService.newChannelFromURI(uri);
         pacURL = uri.spec;

Comment 5

17 years ago
*** Bug 83984 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Created attachment 37263 [details] [diff] [review]
Patch that removes all debug output from nsProxyAutoConfig.js

Comment 7

17 years ago
Wait! Are you adding code that reads user_pref "network.proxy.type" to see if
PAC should be read, or are you just hiding the debug comments?

The debug comments are good, the behavior is what is bad.
(Assignee)

Comment 8

17 years ago
I do not see "PAC:Loading PAC from <URL>" message on linux 2001060408 release
build when I turnning of the proxy using Preferences->Advanced->Proxies dialog,
and restart.

Comment 9

17 years ago
I'm not getting enough sleep.

It happens in Mozilla 0.9 for Win32. I'll check an newer build.

You should check the dupe to what they say, and Asa says it happens on the 
trunk.

Comment 10

17 years ago
Ignore previous commments, they went to the wrong bug...

Is this code checked in?

What is the function of this code?

The problem here is that PAC loads, even if PAC is not the selected proxy type
(direct or manual)

The pref is network.proxy.type, and PAC should only load if it is "2"
(Assignee)

Comment 11

17 years ago
How do you know that PAC if loaded if network.proxy.type != 2? 
I cannot reproduce this with latest window & linux builds.

Comment 12

17 years ago
I've been looking at the log file on my proxy server.

Comment 13

17 years ago
now that I think about it more, if you don't see this behavior in the build, and
you can verify with a trace or a log file, then mark works for me.

I'm going to add this to the network preferences test cases I'm working on, so
if it is broken, it will show in the functional test anyhow.

*** This bug has been marked as a duplicate of 85290 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 15

17 years ago
This is not a duplicate.

If a the action requested in a bug is not clear, please ask for clarification
before slamming code into the tree.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

17 years ago
Blocks: 79893

Updated

17 years ago
QA Contact: benc → pacqa

Comment 16

17 years ago
Serge, can you take a look at these PAC issues? Thanks - Jussi-Pekka
Assignee: jpm → serge
Status: REOPENED → NEW

Comment 17

17 years ago
+ verifyme, makingtest
need to test this.
Keywords: makingtest, verifyme

Comment 18

17 years ago
I think this bug is fixed.  The trace output has been removed from
nsProxyAutoConfig.js.  Furthermore, the nsProtocolProxyService code that
processes the prefs only loads the PAC file if the "type" is 2 (= autoproxy). 

See
http://lxr.mozilla.org/mozilla/source/netwerk/base/src/nsProtocolProxyService.cpp#225

I'd like to shut this bug down.

Comment 19

17 years ago
If you think this is good, then I'm okay with you marking it resolved.

Comment 20

17 years ago
Marking fixed.  
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.