[Settings] More Information for Firmware, Software

RESOLVED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: scravag, Assigned: Evelyn Hung)

Tracking

({feature})

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)
feature

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [LOE:S][ETA:12/1/12])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
As a user I want to be able to click on "More Information" button on Device Information, so that I can see detailed info on Firmware, Hardware and MAC address.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → +
Keywords: feature
Priority: -- → P1
Could you give a example for Firmware and Hardware?

and Mac address is available in Settings -> Wi-Fi -> Manage Networks, Do we need to move it to Device information -> "More Information"?
(Assignee)

Updated

6 years ago
Assignee: nobody → ehung

Comment 2

6 years ago
We're marking this bug with the C1 milestone since it follows the criteria of "unfinished feature work" (see https://etherpad.mozilla.org/b2g-convergence-schedule).

If this work is not finished by Nov19, this bug will need an exception and will be called out at the upcoming Exec Review.
Target Milestone: --- → B2G C1 (to 19nov)
Summary: [Settings] More Information for Firmaware, Hardware and MAC address → [Settings] More Information for Firmware, Hardware and MAC address

Updated

6 years ago
Component: Gaia → Gaia::Settings
(Assignee)

Comment 3

6 years ago
Created attachment 682335 [details]
add placeholder in device info section

Fields need to be filled out: Software, Last Updated, and Firmware Revision.
Need clear definition and gecko support for these.
Attachment #682335 - Flags: review?(timdream+bugs)
Attachment #682335 - Flags: review?(timdream+bugs) → review+
(Assignee)

Comment 4

6 years ago
https://github.com/mozilla-b2g/gaia/pull/6449
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 799500
(Assignee)

Comment 6

6 years ago
Sorry, I think I shouldn't close this bug, since it needs further discussion with OEMs to understand what exactly it is to show. and then make changes later when the information is defined more precisely.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
"Last Updated" is bug 809974.

Updating this bug's summary to reflect the remaining pieces:

* Firmware
* Software

What exactly is supposed to be there?

Can you implement it so that the placeholders are hidden if there's no value available?
Summary: [Settings] More Information for Firmware, Hardware and MAC address → [Settings] More Information for Firmware, Software
Still need more definition on what's to be displayed especially on software / firmware version
Flags: needinfo?(jcarpenter)
(Assignee)

Updated

6 years ago
Depends on: 809974
"Software" field should display OS name and version. eg: "FirefoxOS 1.0.0"

That information is also listed under More Information section ("OS version: 1.0.0"). The duplication is fine.

Re: Firmware, I have no idea. It's important that Larissa added these fields as placeholders in lieu of having specific requirements. If we don't get firmware information, we can just remove the field. Per her 11/14 feedback to the "Web API for device information" email thread:

> I agree with what Josh wrote in his previous email. I added those
> fields as placeholders (as clearly stated in the wireframe) because
> I didn't have concrete requirements about what we wanted to include.
> As a guideline for what entries we should and shouldn't display:
Flags: needinfo?(jcarpenter)
(In reply to Josh Carpenter [:jcarpenter] from comment #9)
> . . .It's important that Larissa added these fields. . .

Meant to say: "important to remember..."

Comment 11

6 years ago
Hi, Chris, do you agree to remove "firmware version" here?
Flags: needinfo?(clee)
Per the OEM email thread, we will need to have firmware field visible for some OEMs.

We need an answer from Evelyn to my question in comment #7: Can you implement so that the firmware field is visible if the value is present, and not visible if the value is empty?

That would allow us the flexibility to show/hide the field on a per-configuration basis.
Flags: needinfo?(clee) → needinfo?(ehung)

Comment 13

6 years ago
Just checked on the device, the location of the content look about right. 

One thing to bring up: some of these strings are extremely long, and I don't think it's a good idea to right-align the values with the header. Can't we use two lines instead (ala settings list with a few font tweaks)? If not for v.1, for v.soon?

Updated

6 years ago
Target Milestone: B2G C1 (to 19nov) → B2G C2 (20nov-10dec)

Comment 14

6 years ago
Let me talk with OEMs to make sure if they can provide such information. 
Meanwhile, we need to make sure where to save firmware version.
Flags: needinfo?(ehung)
Kevin, I still have not received an answer to comment #7 and comment #12.

Evelyn, if you can implement the field to show or hide based on the presence of firmware version, we can close this bug.

Can you please provide an answer to implementing it this way?

Comment 16

6 years ago
Hi, Dietrich, so, if we hide this field, did you mean, we won't want this in v1? 
If we agree to remove this from v1, that would be great to hide this field. :)
No, that is not what I am asking.

I am asking if Evelyn can implement the field so that *if* a firmware version is available, the field is shown. *If* there is no firmware version available, the field is not shown.

That way, we can accommodate *all* OEMs preferences about firmware version display, and customize the build accordingly, and close this bug.

Comment 18

6 years ago
Comment 17 is likely the best path forward here.
(Assignee)

Comment 19

6 years ago
Dietrich, yes I can implement that. But since the setting assignment is globally applied on all fields, so some fields that lack of a value in mozSettings DB will also be hidden. Or, I could make this a special case that only check this field and note due to the comments here.

On the other hand, if we want to support adding firmware version from OEM, that will need Gecko support to design a way for setting the value into mozSettings DB when making a build.
(Assignee)

Comment 20

6 years ago
and I'm waiting for bug 809974 for "Last Updated" field. :'(
(Assignee)

Comment 21

6 years ago
Oh, please ignore comment 20, I realized "Last Updated" field is another issue and won't block this.
(In reply to Evelyn Hung [:evelyn] from comment #19)
> Or, I could make this a special case
> that only check this field and note due to the comments here.

This is fine for V1. We can develop the perfect approach in a subsequent release.

Comment 23

6 years ago
Evelyn will hide this field. ETA = Today. 
We should also create another bug to Gecko engineer to provide a method for OEM to save such information into Firefox OS.
Whiteboard: [LOE:S]

Comment 24

6 years ago
Bug 816899 is created.
(Assignee)

Comment 25

6 years ago
I think I need one more day to address Larissa's comment 13 and wait reviewer's feedback.
Whiteboard: [LOE:S] → [LOE:S][ETA:12/1/12]
(Assignee)

Comment 26

6 years ago
Created attachment 687433 [details]
hide firmware field if the value is not defined

also add software version value that is OS name + OS version
(although the software version needs to be added into Settings
DB from Gecko side, not hard code here)
als fix MAC address is missing because of lazy-loading wifi panel
Attachment #687433 - Flags: review?(timdream+bugs)
(Assignee)

Updated

6 years ago
Duplicate of this bug: 816307
(Assignee)

Comment 28

6 years ago
Comment on attachment 687433 [details]
hide firmware field if the value is not defined

I've addressed review comments from vivien, re-assign him as my reviewer for verifying.
Attachment #687433 - Flags: review?(timdream+bugs) → review?(21)
Comment on attachment 687433 [details]
hide firmware field if the value is not defined

Tim review is enough as long as you have fixed my comment :)
Attachment #687433 - Flags: review?(21) → review+
(Assignee)

Comment 30

6 years ago
https://github.com/mozilla-b2g/gaia/pull/6771
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.