Provide a method for OEM to save firmware version

RESOLVED FIXED in Firefox 19

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: khu, Assigned: shelly)

Tracking

unspecified
B2G C2 (20nov-10dec)
x86
Mac OS X

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Continue from bug 808892. 

We need to make sure we have a way for OEM to give their firmware version and save into Firefox OS. 

Additional question(s): 
1. Should we also need a way for OEM to "update" the firmware version? And how?
(Reporter)

Comment 1

5 years ago
Marco, any comments?
blocking-basecamp: --- → ?
Flags: needinfo?(mchen)

Comment 2

5 years ago
Normally, the build information is put on Android property (ex: ro.build.XXX).
And the properties can be updated from kernel or init.XXX.rc (boot.img) as well as the build.prop (system.img). 
So OEM can update related info into these files by itself.

What we need to do is just to "read" them back and make sure the correct property name with OEM.
Flags: needinfo?(mchen)

Comment 3

5 years ago
So please use this key "deviceinfo.firmware_revision" to write into mozSettings DB. Thanks.
Component: General → Gaia::Settings

Comment 4

5 years ago
Please also add 'deviceinfo.software' which should be OS name + OS version. eg: "FirefoxOS 1.0.0" (UX confirmed, see comment 9 in bug 808892). Thanks!

Please note this issue is intended for a Gecko patch, although it's related to Settings app.
(Assignee)

Comment 5

5 years ago
Created attachment 687614 [details] [diff] [review]
v1: Add firware revision and software info

Hi Chris, in this patch, I've added keys of firmware revision and software info to the IndexedDB, just like what I did in bug 790158. I've cleaned up some coding style issue from my previous patch as well (if that's okay).

Could you give my some feedback? Thanks a lot.
Attachment #687614 - Flags: feedback?(jones.chris.g)
blocking-basecamp: ? → +
Priority: -- → P1
Comment on attachment 687614 [details] [diff] [review]
v1: Add firware revision and software info

This seems fine, but we can't use the name "Firefox" in unbranded assets.  Let's go with "Boot2Gecko" for now.
Attachment #687614 - Flags: feedback?(jones.chris.g) → feedback+
(Assignee)

Comment 7

5 years ago
Created attachment 688075 [details] [diff] [review]
v1: Add firware revision and software info, clean up.

Thanks Chris, I've changed the OS name from FirefoxOS to Boot2Gecko.

Here's the try server result:
https://tbpl.mozilla.org/?tree=Try&rev=d1ac572b1342
(The Bi of B2G otoro opt doesn't seem related)
https://tbpl.mozilla.org/?tree=Try&rev=d81d1fb4ccb3
Attachment #687614 - Attachment is obsolete: true
Attachment #688075 - Flags: review?(jones.chris.g)
(Assignee)

Updated

5 years ago
Assignee: nobody → slin
Attachment #688075 - Flags: review?(jones.chris.g) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed

Comment 9

5 years ago
https://hg.mozilla.org/mozilla-central/rev/75ae0108f7f3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/d6239ba4d40f
https://hg.mozilla.org/releases/mozilla-b2g18/rev/7a4db80cc3a8
status-b2g18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Keywords: checkin-needed
Target Milestone: --- → B2G C2 (20nov-10dec)
You need to log in before you can comment on or make changes to this bug.