Closed Bug 808994 Opened 8 years ago Closed 8 years ago

B2G SMS: Expose the `strict7BitEncoding` setting through the setting API.

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla19
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: jaoo, Assigned: jaoo)

References

Details

Attachments

(1 file, 2 obsolete files)

Attached file WIP (obsolete) —
We have to enable Latin characters replacement with corresponding ones in GSM SMS 7-bit default alphabet through the setting API.
Assignee: nobody → josea.olivera
Blocks: b2g-sms, 804960
blocking-basecamp: --- → ?
See Also: → 790192
Attached patch v1 (obsolete) — Splinter Review
Exposing the `strict7BitEncoding` setting through the settings API.
Attachment #678689 - Attachment is obsolete: true
Attachment #678787 - Flags: review?(vyang)
Comment on attachment 678787 [details] [diff] [review]
v1

Review of attachment 678787 [details] [diff] [review]:
-----------------------------------------------------------------

Bug 804960 comment #19 from Mounir, maybe we can simply mirror the settings entry back to preference:

  ::in gecko/b2g/chrome/content/settings.js
  SettingsListener.observe('ril.sms.strict7BitEncoding.enabled', false, function(value) {
    Services.prefs.setBoolPref('dom.sms.strict7BitEncoding', value);
  }
Attachment #678787 - Flags: review?(vyang)
Attached patch v2Splinter Review
Mirror the settings entry back to preference. Much more easier. Thx Vicamo!
Attachment #678787 - Attachment is obsolete: true
Attachment #678856 - Flags: review?(vyang)
Comment on attachment 678856 [details] [diff] [review]
v2

Review of attachment 678856 [details] [diff] [review]:
-----------------------------------------------------------------

Nice Job!
Attachment #678856 - Flags: review?(vyang) → review+
Hey Dietrich, could you please review the blocking-basecamp nomination for this bug?, the work from bug 804960 depends on this bug.
https://hg.mozilla.org/mozilla-central/rev/7dbd49fe775e
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 841699
You need to log in before you can comment on or make changes to this bug.