Last Comment Bug 809055 - Moving Firefox to background while playing a flash video in full screen mode and bring it back to view will freeze the app
: Moving Firefox to background while playing a flash video in full screen mode ...
Status: REOPENED
: hang, regression
Product: Firefox for Android
Classification: Client Software
Component: Plugins (show other bugs)
: 19 Branch
: ARM Android
: -- critical with 5 votes (vote)
: Firefox 20
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
:
Mentors:
Depends on: 827407
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-06 08:24 PST by Cristian Nicolae (:xti)
Modified: 2016-07-29 14:30 PDT (History)
28 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
affected
verified
fixed
fixed
+
wontfix
+
wontfix
23+
18+


Attachments
Restore fullscreen plugins after document becomes active (1.34 KB, patch)
2012-12-14 11:59 PST, James Willcox (:snorp) (jwillcox@mozilla.com)
blassey.bugs: review+
Details | Diff | Splinter Review

Description Cristian Nicolae (:xti) 2012-11-06 08:24:26 PST
Firefox 19.0a1 (2012-11-06)
Device: Galaxy S2
OS: Android 4.0.3

Steps to reproduce:
1. Go to youtube.com (desktop site)
2. Select a video from the list and play it in full screen mode
3. Tap on device Home button
4. Tap on Firefox shortcut to bring the app back into view

Expected result:
The app is not longer in full screen mode after step 4. Also no hangs or freezes will occur.

Actual result:
The app freezes after step 4.
Comment 1 Kevin Brosnan [:kbrosnan] 2012-11-07 15:26:11 PST
Does this happen on any other video or just youtube? Is this Flash playback or html5 <video>?
Comment 2 Cristian Nicolae (:xti) 2012-11-12 09:09:19 PST
This is happening just for flash playback (on any website). It doesn't occur on any HTML5 video.
Comment 3 Cristian Nicolae (:xti) 2012-11-13 01:39:35 PST
This issue occurs now on Aurora too, since bug 809005 was fixed.

--
Firefox 18.0a2 (2012-11-12)
Device: Galaxy S2
OS: Android 4.0.3
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2012-12-13 10:39:19 PST
Snorp, what's your plan here?
Comment 5 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-12-13 11:40:25 PST
Haven't really looked at this closely yet, but if I'd guess it's probably caused by Flash holding a lock while we are blocked in scheduleResumeComposition(), similar to other deadlocks.
Comment 6 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-12-13 13:45:11 PST
I've confirmed that this is caused by the thing I described above (though it's pausing composition, not resuming). Brad and I discussed a possible solution that takes the gecko main loop out of the composition pause process. Basically call nsWindow::SchedulePauseComposition directly from the UI thread.
Comment 7 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-12-14 11:59:31 PST
Created attachment 692412 [details] [diff] [review]
Restore fullscreen plugins after document becomes active
Comment 8 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-12-14 12:00:20 PST
It turns out we didn't actually have the fullscreen surface displayed, which is why Flash never gave up the lock (it waits on the surface). Attached patch fixes that, and I don't get a deadlock.
Comment 9 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-12-17 07:07:18 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/f773ab3d5146
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-12-17 16:38:27 PST
https://hg.mozilla.org/mozilla-central/rev/f773ab3d5146
Comment 11 Ioana Chiorean 2012-12-19 06:56:44 PST
Firefox 20.0a1 (2012-11-19)
Device: Galaxy Nexus/ Galaxy Note 
OS: Android 4.1.1/ 4.0.4

This is not reproducible on latest Nightly following steps from description. Marking bug as VERIFIED FIXED.
Comment 12 Alex Keybl [:akeybl] 2013-07-03 12:13:34 PDT
Snorp, what are your plans for FF23/24 now that this is backed out for bug 827407?
Comment 13 Lukas Blakk [:lsblakk] use ?needinfo 2013-07-18 10:48:35 PDT
At this point, for FF23 we'll have to wontfix this and make a note in Known Issues.
Comment 14 Lukas Blakk [:lsblakk] use ?needinfo 2013-08-01 16:37:54 PDT
Noted in 'Known Issues'
Comment 15 Terrell Kelley 2013-08-16 21:58:28 PDT
Next time, I think it would be a good idea to mention that this a mobile-only  problem in the "Known Issue" notes. No need to worry users unnecessarily.
Comment 16 Thomas Olson 2013-08-19 07:40:30 PDT
^ "Product: 	Firefox for Android"

>_>

<_<
Comment 17 bhavana bajaj [:bajaj] 2013-08-26 14:51:50 PDT
needsinfo on :snorp to help with comment 12 given we are only left with two more mobile beta's for Fx24 as well.
Comment 18 bhavana bajaj [:bajaj] 2013-09-04 13:11:46 PDT
At this point, for FF23 we'll have to wontfix this and carry on the note in Known Issues
Comment 19 James Willcox (:snorp) (jwillcox@mozilla.com) 2013-09-09 07:17:32 PDT
The fix we had before was correct, IMHO, but I guess it caused some bad Flash behavior (crashing). I haven't had time to look at this or other Flash bugs but hope to soon.
Comment 20 Gary 2013-10-31 21:58:40 PDT
This happens to me several times a day. It is not just on YouTube, it is on all flash or non flash video. If I go to another tab and then go back it is frozen about 80% of the time and nothing you can do will fix it. It can sometimes be prevented by clicking on history clear and clear the cache, but even that does not always work! Just thought I would let you  know.
Comment 21 sjw 2013-12-13 06:36:37 PST
(In reply to Lukas Blakk [:lsblakk] from comment #14)
> Noted in 'Known Issues'

This should be in 'Mobile' instand of 'Desktop'.
Comment 22 Christian Ascheberg 2014-02-04 09:02:45 PST
(In reply to Lukas Blakk [:lsblakk] from comment #14)
> Noted in 'Known Issues'

This bug is still incorrectly listed in the FF 27 desktop release notes, while it is not included in the current mobile release notes.
Comment 23 Virgo Pärna 2014-02-04 10:13:57 PST
It has happened for me in desktop Firefox 26 also. Not in every switching between fullscreen flash video and Firefox, but if happen to do it multiple times, then it tends to happen. Both  in Youtube and in Twitch. Killing plugincontainer helps to unfreeze the Firefox.
Windows is Windows XP and it has happend with last couple of flash versions.
Comment 24 Aaron Train [:aaronmt] 2014-02-04 11:43:29 PST
> The fix we had before was correct, IMHO, but I guess it caused some bad
> Flash behavior (crashing). I haven't had time to look at this or other Flash
> bugs but hope to soon.

Snorp's been all over Flash lately. Let's entertain the thought to see if Snorp is working on this?
Comment 25 James Willcox (:snorp) (jwillcox@mozilla.com) 2014-02-07 07:28:46 PST
I haven't, but I will.
Comment 26 Pascal 2014-02-27 08:01:15 PST
Why is this bug in the 27.0.1 desktop release notes at https://www.mozilla.org/en-US/firefox/27.0.1/releasenotes/ when it is an Android only bug?
Comment 27 Aaron Train [:aaronmt] 2014-02-27 08:06:34 PST
(In reply to Pascal from comment #26)
> Why is this bug in the 27.0.1 desktop release notes at
> https://www.mozilla.org/en-US/firefox/27.0.1/releasenotes/ when it is an
> Android only bug?

We asked that question in comment #22. Still waiting for a release manager to make an adjustment.
Comment 28 Lukas Blakk [:lsblakk] use ?needinfo 2014-03-13 12:11:26 PDT
This has been resolved in our database and in svn for trunk/stage/production notes and should not come back in future versions. http://viewvc.svn.mozilla.org/vc?view=revision&revision=125342

Note You need to log in before you can comment on or make changes to this bug.