about:pics crashes the browser - Trunk [@ nsDocShell::DoURILoad]

VERIFIED WORKSFORME

Status

()

Core
Networking
--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: ckritzer (gone), Assigned: neeti)

Tracking

({crash, topcrash})

Trunk
mozilla0.9.2
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Ooooookay.  So on a whim, I typed 'about:pics' into the URL field, hit 
ENTER and the build crashed without so much as a wimper.  Weirdness.

Mitch, I think this might be yours [technically], but I'm not 100% sure.  As 
usually, if any of your IMF team be caught or...

Oh, sorry, wrong line.

Uh, if I got the component wrong, please correct.  Thanks!
(Reporter)

Comment 1

17 years ago
Whoops! 

The builds I used to test were:
-MacOS91 2001-05-14-04-trunk
-Win98SE 2001-05-14-06-trunk
-LinRH62 2001-05-14-05-trunk

And no, I didn't use any of those builds to file this bug... ;-)
(Reporter)

Comment 2

17 years ago
Okay, it looks like about:license also crashes the browser.  I'm going to 
see if I can dig up the old 'about:*' list from 4.x and see if all the about: urls 
which don't exist in the current browser behave this way...
(Reporter)

Comment 3

17 years ago
Wow.  Even about:ckritzer crashes it.

Well, since it's so reproducible, I'll add a talkback report when I can get at 
the server.
This is a networking bug:

#0  0x40da8500 in nsDocShell::DoURILoad (this=0x84f0938, aURI=0x861bd90, 
    aReferrerURI=0x0, aOwner=0x84dd308, aLoadCmd=0, aPostData=0x0, aHeadersData=0x0)
    at nsDocShell.cpp:3913
#1  0x40da7c74 in nsDocShell::InternalLoad (this=0x84f0938, aURI=0x861bd90, 
    aReferrer=0x0, aOwner=0x0, aInheritOwner=1, aStopActiveDoc=0, 
    aWindowTarget=0xbfffd3fc, aPostData=0x0, aHeadersData=0x0, aLoadType=1,
aSHEntry=0x0)
    at nsDocShell.cpp:3816
#2  0x40d9792a in nsDocShell::LoadURI (this=0x84f0938, aURI=0x861bd90,
aLoadInfo=0x0, 
    aLoadFlags=0) at nsDocShell.cpp:529
#3  0x40d9f393 in nsDocShell::LoadURI (this=0x84f0938, aURI=0x861a868, aLoadFlags=0)
    at nsDocShell.cpp:1978
#4  0x4013ea65 in XPTC_InvokeByIndex (that=0x84f0948, methodIndex=8, paramCount=2, 
    params=0xbfffd85c) at xptcinvoke_unixish_x86.cpp:138

(gdb) frame 0
#0  0x40da8500 in nsDocShell::DoURILoad (this=0x84f0938, aURI=0x861bd90, 
    aReferrerURI=0x0, aOwner=0x84dd308, aLoadCmd=0, aPostData=0x0, aHeadersData=0x0)
    at nsDocShell.cpp:3913
3913        channel->SetOriginalURI(aURI);
(gdb) p channel
$2 = {mRawPtr = 0x0}
Assignee: mstoltz → neeti
Component: Security: General → Networking
Keywords: crash, mozilla0.9.1
QA Contact: ckritzer → tever
perhaps we should check for success of the NS_OpenURI?

Comment 7

17 years ago
Win2K 2001051504
Talkback ID: TB30475990Q
*** Bug 80984 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.2

Comment 9

17 years ago
This crash *was* showing up in Talkback topcrash reports in large numbers 
(under the docshell.dll and nsDocShell::DoURILoad stack signatures)...but the 
latest entries show this crashing with build 2001051710. adding topcrash keyword 
and Trunk [@ nsDocShell::DoURILoad] for tracking.  

If any new crashes show up in Talkback, I will update the bug.  Has anyone been 
able to reproduce this crash with recent builds? It might have been fixed 
recently.
Keywords: topcrash
Summary: about:pics crashes the browser → about:pics crashes the browser - Trunk [@ nsDocShell::DoURILoad]

Comment 10

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc

Comment 11

17 years ago
CKritzer - Are you able to reproduce this in the current builds?
(Reporter)

Comment 12

17 years ago
Jaime: Nope.  Not today, apparently.

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

17 years ago
Marking VERIFIED FIXED on:
-MacOS91 2001-05-23-08-trunk
-Win98SE 2001-05-23-09-trunk
-LinRH62 2001-05-23-08-trunk

Status: RESOLVED → VERIFIED
Crash Signature: [@ nsDocShell::DoURILoad]
You need to log in before you can comment on or make changes to this bug.