Browser Segment Faults Unloading Java Plugin at Quit

VERIFIED FIXED

Status

()

VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: km, Assigned: peterlubczynski-bugs)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
The Browser seg faults when I quit trying to unload the Java Plugin.

#0  0xff298b98 in nsCOMPtr_base::~nsCOMPtr_base ()
   from /usr/local/ns/nightly/mozilla/./libxpcom.so
#1  0xfd6034f4 in nsPluginTag::TryUnloadPlugin ()
   from /usr/local/ns/nightly/mozilla/components/libgkplugin.so
#2  0xfd603268 in nsPluginTag::~nsPluginTag ()
   from /usr/local/ns/nightly/mozilla/components/libgkplugin.so
#3  0xfd606b28 in nsPluginHostImpl::Destroy ()


It doesn't matter if an Applet is ever run, as long as the javaplugin
is in the plugins directory, it always seg faults when the browser
quits.

This is on Solaris, but I see the same behavior on Linux.

Comment 1

18 years ago
i am blocked by bug 80170 Just cannot install the plugin.
Depends on: 80170

Comment 2

18 years ago
This is probably bug 76936.  Looks like the second patch (to fix the nsComPtr 
release) made it into the 0.9 branch but not the trunk.

Comment 3

18 years ago
Nope this is a dupe of 80960

*** This bug has been marked as a duplicate of 80960 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
You might want to look into the history of bug 76936 before jumping to that 
conclusion.

Comment 5

18 years ago
Created attachment 34872 [details] [diff] [review]
This is Blizzard's patch that went in the 0.9 branch

Comment 6

18 years ago
cc: Chris Blizzard.

Chris - recall the Java/crash/shutdown bug 73936?  You checked in a fix to the 
0.9 branch but not the trunk.  Should we get the patch into the trunk?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

18 years ago
okay, I r=peterl this patch. So all we need is a sr=. It should have gone in. I 
thought Chris checked it in. All we need is a super review.
Assignee: av → peterlubczynski
Status: UNCONFIRMED → NEW
Ever confirmed: true
Peter, find a victim that isn't me and send mail.

Comment 9

18 years ago
Looks good. sr=blake
(Assignee)

Comment 10

18 years ago
got the sr=blake in IRC. Checked in, marking FIXED:

/cvsroot/mozilla/modules/plugin/nglsrc/nsPluginHostImpl.cpp,v  <--  
nsPluginHostImpl.cpp
new revision: 1.249; previous revision: 1.248
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Shaver argued that the Java-plugin-specific hack should not be added to the
trunk, only to the 0.9 branch.  Isn't there a better fix (or fixes, if the JVM
plugin needs fixing too), that does not require hardcoding a particular plugin's
interface into generic plugin code?

/be
(Assignee)

Comment 12

18 years ago
I totally agree and there are other nsbeta1 bugs out there to fix this for all 
XPCOM plugins. But, at leat this patch will stop the flood of plugin bugs.

Comment 13

18 years ago
no seg fault seen on 20010517 trunk on linux after quitting browser after 
loading applet on page
Status: RESOLVED → VERIFIED

Comment 14

18 years ago
Brendan: I agree, but given the choice between hardcodedness + crash and 
hardcodedness, I'd choose the latter.  Peter told me on IRC that he'd file a new 
bug to cover the real issue.  Peter?
(Assignee)

Comment 15

18 years ago
Created attachment 35097 [details] [diff] [review]
demo copy of new patch to supercede the one that fixed this bug
(Assignee)

Comment 16

18 years ago
This bug not only effects Java but all XPCOM plugins. Java is just easy to pick 
on. To see an example of this, try watching a video at abcnews.com with the Real 
player. Close the window with the movie and you should crash like with Java. 
Even simple testcases crashed. 

I've been testing this patch and it looks like a real winner. Fixes all the 
crashes, even going back and forward, closing window, and even about:plugins.

Wondering if I can get some reviews....err..perhaps I should find the real bug 
#...

Comment 17

18 years ago
(So if it was that easy, why didn't we do it before?)  Why not remove the 
Java-specific code entirely?  shaver should be the one to review this because 
this is largely the approach that he was advocating in the other bug.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 18

18 years ago
I didn't realize it was going to be that easy. ;-)

This seems to be working very well so far, but I need to do some more testing. I 
left the Java code in the comments because it's a demo patch.

I need to try the Beatnik XPCOM plugin and Java.

[Bug 79872] crash clicking on realplayer movie link
is probably a duplicate of this bug (now). 
(Assignee)

Comment 19

18 years ago
Cleaned up by fixing crasher Bug 79872.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 20

18 years ago
confirmed with reporter via mail that this is indeed working now. VERIIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.