Closed Bug 809577 Opened 8 years ago Closed 8 years ago

nsIAudioManager undefined on desktop builds

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 809972

People

(Reporter: jedp, Assigned: jedp)

Details

Attachments

(1 file)

Desktop builds get the following error on runtime:

JavaScript error: chrome://browser/content/settings.js, line 70: nsIAudioManager is undefined

We should ifdef around the gonk-only code.
Comment on attachment 679319 [details] [diff] [review]
ifdef around gonk-only audiomanager code

I'm good with this but I suspect we need a brief review from B2G team.
Attachment #679319 - Flags: review?(benadida) → review+
I verified that function is workable on Otoro with this patch. And thanks for the help on this regression.
(In reply to Marco Chen [:mchen] from comment #3)
> I verified that function is workable on Otoro with this patch. And thanks
> for the help on this regression.

Excellent.  Thank you, Marco!
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → DUPLICATE
Duplicate of bug: 809972
Funny story, I already landed the patch in this one and mid-aired trying to mark it...
https://hg.mozilla.org/integration/mozilla-inbound/rev/6f9dd07d9d64
No worries - as long as it works in the end!  Thanks as always, Ryan.
Thanks for creating the fix so quickly, Jed! For future reference, to avoid duplicating work, please make sure you mark regressions as blocking the bug that introduced the regression (bug 809972 in this case, as can be found out by hg blame.) That way folks who worked on and reviewed the original bug are aware of the regression.

Also, as Ben said, a B2G peer should have done the final review on this. The Bugzilla "etiquette" typically is that non-peers set feedback+ and only a peer sets review+. This is pretty universal across Gecko.
Blocks: 809972
Thank you for the comments and clarification, Philipp.  I understand now what to do in the future.  Cheers!
j
No longer blocks: 809972
You need to log in before you can comment on or make changes to this bug.