Enable capitalization and word suggestions for Contacts' names, location, and notes

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Set inputmode="latin-prose" to enable initial capitalization and word suggestions for new contacts' first name, last name, company name, street address, city, country, and notes fields.
(Assignee)

Comment 1

6 years ago
Created attachment 679455 [details] [diff] [review]
inputmode=latin-prose.patch

Set inputmode="latin-prose" to enable initial capitalization and word suggestions for new contacts' first name, last name, company name, street address, city, country, and notes fields.
Attachment #679455 - Flags: review?(jmcanterafonseca)
Attachment #679455 - Flags: feedback?(dflanagan)
(Assignee)

Updated

6 years ago
Blocks: 797155
Comment on attachment 679455 [details] [diff] [review]
inputmode=latin-prose.patch

feedback+  Looks good.  Note that the latest in bug 796544 is that we might change the inputmode attribute to x-inputmode.  But assuming that you land this soon, we'll just change it later in one big patch.
Attachment #679455 - Flags: feedback?(dflanagan) → feedback+
(Assignee)

Comment 3

6 years ago
Comment on attachment 679455 [details] [diff] [review]
inputmode=latin-prose.patch

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Not a regression
User impact if declined: When entering new contacts, the user will need to manually shift to capitalize the contact's first name, last name, company name, city, and country. Android and iOS automatically capitalize these contact fields.
Testing completed: Tested locally
Risk to taking this patch (and alternatives if risky): Low risk because it just adds an inputmode hint to an existing text input.
Attachment #679455 - Flags: approval-gaia-master?(21)
(Assignee)

Comment 4

6 years ago
Comment on attachment 679455 [details] [diff] [review]
inputmode=latin-prose.patch

r?
Attachment #679455 - Flags: review?(jmcanterafonseca) → review?(jmcf)

Comment 5

6 years ago
changes look ok to me, just adding an attribute,  but for non latin languages what would the effect of that attribute?. I guess that for latin languages it will enable caps when cursor is positioned in the field and the field is empty, right?
(Assignee)

Comment 6

6 years ago
Gecko doesn't do anything with the inputmode attribute; it simply passes the attribute value through to platform code, which may choose to display a special input widget. Gaia's non-latin IMEs currently ignore the inputmode attribute.

Gaia's latin IME switches the keyboard to uppercase mode when the cursor is positioned at the head of a text field, whether the text field is empty or not. The user can unshift the keyboard if they don't want the text field's first character to be capitalized.

Updated

6 years ago
Attachment #679455 - Flags: review?(jmcf) → review+
If this hasn't landed yet, I think you should change inputmode to x-inputmode before landing.
Your patch will not work without that change.
The depends on bug has been used to close a blocking+ bug (bug 808921). So I guess this work is part of it. 

blocking-basecamp+.

Also make sure to fix mounir's comment before landing.
blocking-basecamp: --- → +

Comment 12

6 years ago
Reviewed and verified on build: 2012123107020
"Unagi" device and "Gonk" OS
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.