Last Comment Bug 809745 - Entering 'localhost' in the location bar initiates a Google search
: Entering 'localhost' in the location bar initiates a Google search
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla19
Assigned To: abhishek rajput
:
Mentors:
: 812116 812267 (view as bug list)
Depends on:
Blocks: 63736 693808
  Show dependency treegraph
 
Reported: 2012-11-07 20:51 PST by Kyle Kalstabakken
Modified: 2013-02-08 02:59 PST (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
+
verified


Attachments

Description Kyle Kalstabakken 2012-11-07 20:51:29 PST
When you type 'localhost' in the location bar and hit enter, a Google search is performed.
This also occurs for any number of subdirectories, as long as you don't specify an actual file with file extension (ie, |localhost(/directory/)*|).

I expected to be shown the index page of the site I'm running on my machine. This does work if you type http://localhost

This first happens in the Nightly from Nov 3.

Just scanning the pushlog, it looks like this is caused by:
ded200210541	Abhishek Rajput — Bug 693808 - Make number keywords in locationbar be searched as normal terms. r=jst

... which makes sense because 'localhost' doesn't have any periods, colons or ?s in it. Adding any of these works as expected (eg, 'localhost:80', 'localhost?', 'localhost/index.html')
Comment 1 Matthias Versen [:Matti] 2012-11-08 02:24:29 PST
this is related to bug 150025
Comment 2 João Rosado 2012-11-08 05:27:41 PST
Also don't forget about internal network sites.
"myIntranetMachine/Site/" also causes the same problem and is a valid address.

As a note, these problems do not happen with browser.urlbar.trimURLs set to false.
Comment 3 Jerry Baker 2012-11-08 11:11:24 PST
(In reply to João Rosado from comment #2)
> As a note, these problems do not happen with browser.urlbar.trimURLs set to
> false.

They do using today's nightly. TrimURLs has no effect.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-11-14 13:14:28 PST
abhishek, this was caused by your patch and seems like an important issue to resolve. Do you have any ideas how we could address it?
Comment 5 Alex Keybl [:akeybl] 2012-11-14 16:46:28 PST
Can we just backout bug 693808 from FF19 before the merge to prevent this from hitting Aurora and then resolve for FF20?
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-11-14 16:51:58 PST
Yep - I'll do that.
Comment 7 Matthias Versen [:Matti] 2012-11-15 02:24:34 PST
*** Bug 812116 has been marked as a duplicate of this bug. ***
Comment 8 Matthias Versen [:Matti] 2012-11-15 20:30:56 PST
*** Bug 812267 has been marked as a duplicate of this bug. ***
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-11-21 13:19:19 PST
Fixed by the backout of bug 693808.
Comment 10 Jerry Baker 2012-12-07 09:10:53 PST
This regressed again starting with today's nightly.
Comment 11 Jerry Baker 2012-12-07 09:13:31 PST
Oddly, 'localhost' doesn't trigger a Google search, but entering LAN machine names does.
Comment 12 Jerry Baker 2012-12-07 09:15:18 PST
In fact, the bug is even worse than that. It is now impossible with FF to visit a LAN machine. Typing 'http://vega' is automatically changed to http://www.vega.com, and 'vega' initiates a Google search.
Comment 13 Jerry Baker 2012-12-07 09:41:32 PST
Works again with a later build.
Comment 14 Cornel Ionce [QA] (:cornel_ionce) 2013-02-08 02:59:42 PST
Tested on: Windows 7x64, Ubuntu 12.10 and Mac OS X 10.8 - using Firefox 19 beta 5. 
Marking as verified fixed. 
If someone is able to reproduce, please reopen it.

Note You need to log in before you can comment on or make changes to this bug.