bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

'Share' submenu of application menu not scrollable and unable to share from same menu

VERIFIED FIXED

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: aryx, Assigned: sriram)

Tracking

({regression, reproducible, smoketest})

18 Branch
ARM
Android
regression, reproducible, smoketest
Points:
---

Firefox Tracking Flags

(firefox18+ wontfix, firefox19+ verified, firefox20 verified, firefox21 verified, fennec18+)

Details

Attachments

(5 attachments)

Firefox for Android Aurora 20121107 and Nightly 20121107, Android 4.1.2 (stock), Google Nexus S

Opening the main menu, tapping 'Share' opens the submenu with sharing providers, but this can't be scrolled, neither in portrait nor in landscape mode.

Scrolling the Share menu opened from the address bar context menu works as expected.
Using the same build, this works perfectly fine for me; see vid: http://www.youtube.com/watch?v=PUy8BiPC7cU
Now on the Nexus S (as opposed to the Galaxy Nexus), I can reproduce.
Assignee: nobody → sriram
Keywords: regression, regressionwindow-wanted
Actually this really depends on how many items you have in the share menu. 

Arch, can you paste a screenshot of the menu open?
Created attachment 679674 [details]
share menu in landscape mode (looks the same from url bar)
Created attachment 679675 [details]
share providers not visible in landscape mode
Yeah I can reproduce, not only does can you not scroll but you can't share (my taps are going nowhere).

Updated

6 years ago
tracking-fennec: --- → ?
status-firefox18: --- → affected
status-firefox19: --- → affected
Keywords: reproducible, smoketest
Summary: 'Share' submenu of application menu not scrollable → 'Share' submenu of application menu not scrollable and unable to share from same menu

Updated

6 years ago
Version: Trunk → Firefox 18
tracking-fennec: ? → 18+
Sriram - Any idea when you can get to this?
Flags: needinfo?(sriram)
I guess that this issue is specific to Nexus S, because I cannot reproduce it on the latest Nightly build. The Share list scrolls as expected, both in portrait and landscape modes.

Everything works as expected for me on Aurora either.

--
Firefox 19.0a1 (2012-11-19)
Device: Galaxy S2
OS: Android 4.0.3
(Assignee)

Comment 9

6 years ago
This is working on S2. Please report if there is a problem in Nexus S still.
Flags: needinfo?(sriram)
Yes, issue still exists with Nightly 20121203.
Created attachment 688424 [details]
Case 1 (not working)

I have the same issue on Galaxy S2 from trunk (20) to Beta (17).

Case 1: When the menu is displayed by the physic menu button on the S2, I see a scroll bar at the right, but can't move the list or click on any item.

Case 2: But, when the menu is displayed by the Firefox menu button, it works.

I run CyanogenMod 10, if it helps.
Created attachment 688425 [details]
Case 2 (working)

Submenu displayed by the Firefox's menu button
Duplicate of this bug: 820968
Where we at with this Sriram?
Sriram, still reproducible on the Nexus S, do you have one of those to debug with?
Flags: needinfo?(sriram)
(Assignee)

Comment 16

6 years ago
I don't have a Nexus S with ICS to test this. I tried on a Note with ICS, and didn't have any such issues.

If the time taken to resolve the intent, get the list of applications, inflate it and show on a mobile like Nexus S is expensive, I would recommend using the Gingerbread like "ActivityChooser" if there is a "h/w menu button". That would solve this problem. Is that fine?
Flags: needinfo?(sriram)
(Assignee)

Comment 17

6 years ago
At https://hg.mozilla.org/mozilla-central/file/tip/mobile/android/base/GeckoApp.java#l624 :
An addition check of "!hasPermanentMenukey()" would bring up the old activity-chooser.
Sriram if you need a Nexus S there is one in the QA Box o' devices on the left of my desk in the QA area.
Looks like we know what is going on here no need for a regression range.
Keywords: regressionwindow-wanted
Sriram - We need to figure out short-term and long-term approaches to fixing this bug.
Flags: needinfo?(sriram)
I found a working case:

Keep holding the Share button something like 1 or 2 seconds, then release it. You can now scroll the submenu.

(Something probably needs to be fully loaded)
(Assignee)

Comment 22

6 years ago
Do we use the idea in comment 17?
Flags: needinfo?(sriram)
tracking-fennec: 18+ → 19+
Given that we have this problem and bug 801043, maybe we should just rollback ALL code to use the Android chooser, like we used to, and then work on this and this bug and bug 801043 using bug 825799 as a way forward.

I don't like having this kinda work sometimes, but never the way we want (bug 801043). I'd rather get Fx19 and Fx20 working as well as possible using the old android chooser and work on implementing our ideal design in Fx21.

Thoughts Ian?
Flags: needinfo?(ibarlow)
Yeah, agreed. If this and bug 801043 aren't easy fixes, let's roll back until this is working right everywhere.
Flags: needinfo?(ibarlow)

Comment 25

6 years ago
I'm using Firefox 18 on a Nexus 7 (CM10.1 Android 4.2.1), no problem here.
On my Galaxy Note 1 running FF18 (CM10.1 Android 4.2.1) the issue is here.
I'd like to see a rollback to stock Android sharing menu, as far as I'm concerned for ever.
This is too late for mozilla-18; suggested wont-fix on status flag.

Comment 27

6 years ago
'Too late' for a fix of an important feature?
(Assignee)

Comment 28

6 years ago
Created attachment 698093 [details] [diff] [review]
Patch

The uses a Share Activity chooser -- like good old days.
Did I just a kill a feature I did? :O :O :O
Attachment #698093 - Flags: review?(mark.finkle)
Attachment #698093 - Flags: review?(mark.finkle) → review+

Comment 29

6 years ago
same issue with ff18 on Sony Xperia S with CM10. long pressing share menu resolves this but not a very elegant solution and I hope not the long term one!
I get the same thing on my Galaxy S running Jelly Bean using Nightly.
(Assignee)

Comment 32

6 years ago
I pushed it today. So tomorrow you could be able to share without any hassle. :)
https://hg.mozilla.org/mozilla-central/rev/0a8823187cdb
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
(Assignee)

Comment 34

6 years ago
Comment on attachment 698093 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Custom share submenu
User impact if declined: So many complaints in Play Store and twitter about going custom, and lack of scrolling.
Testing completed (on m-c, etc.): Landed yesterday on m-c 
Risk to taking this patch (and alternatives if risky): Very very low. This removes a lot of code and reverts back to default version (which is what we support for Gingerbread phones).
String or UUID changes made by this patch: None.
Attachment #698093 - Flags: approval-mozilla-beta?
Attachment #698093 - Flags: approval-mozilla-aurora?
Yup, downloaded Nightly this morning, and sharing works again. woot :)
tracking-fennec: 19+ → 18+
tracking-firefox18: --- → ?
Target Milestone: Firefox 21 → ---
Comment on attachment 698093 [details] [diff] [review]
Patch

Approving on aurora considering the user impact and risk profile here.
Attachment #698093 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Taking the user feedback into account, we will consider this bug as a ride-along if we end up having a 18.0.1 depnding on some QA feedback

Request to QA to get as much testing around this issue.
tracking-firefox18: ? → +
tracking-firefox19: --- → +
QA Contact: aaron.train
Verified fixed (restored old functionality) on trunk mozilla-21 (mozilla-central) via Samsung Galaxy Nexus (Android 4.2.1), Samsung Galaxy SII (Android 4.0), and Motorola Droid Bionic (Android 2.3.4).
Status: RESOLVED → VERIFIED
status-firefox20: --- → affected
status-firefox21: --- → verified
Remember to flip to fixed please :-)
status-firefox20: affected → fixed
Comment on attachment 698093 [details] [diff] [review]
Patch

Approving the low risk fix for beta , based on Fx18 feedback on this issue
Attachment #698093 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
We don't have any mobile FF18.0.1 drivers, so marking this bug as wontfix given its lack of criticality.
status-firefox18: affected → wontfix

Updated

6 years ago
status-firefox19: affected → fixed

Comment 44

6 years ago
Work on Firefox 19 beta who came yesterday.

Updated

6 years ago
status-firefox19: fixed → verified

Updated

6 years ago
Duplicate of this bug: 836322

Updated

5 years ago
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.