Last Comment Bug 809865 - Disable inputmode for Firefox 17 and Firefox 18
: Disable inputmode for Firefox 17 and Firefox 18
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on: 746142
Blocks: 796544
  Show dependency treegraph
 
Reported: 2012-11-08 07:12 PST by Mounir Lamouri (:mounir)
Modified: 2012-11-21 07:58 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
disabled
+
disabled


Attachments
Patch (9.39 KB, patch)
2012-11-08 07:21 PST, Mounir Lamouri (:mounir)
bugs: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2012-11-08 07:12:47 PST
inputmode has been introduced in Firefox 17. Since then, Hixie came with a proposal and neither Jonas and I can say for sure what would be the best solution. Unfortunately, in this situation, shipping this feature in Firefox Android and Firefox OS would be dangerous for the Web.

I think the best plan would be to:
1. Disable the feature for Firefox 17 and Firefox 18 (which is going to disable for Firefox OS);
2. Hide the feature behind a pref in m-c;
3. Take our time to find out a real good solution.
Comment 1 Mounir Lamouri (:mounir) 2012-11-08 07:21:21 PST
Created attachment 679672 [details] [diff] [review]
Patch
Comment 2 Mounir Lamouri (:mounir) 2012-11-08 07:46:27 PST
Olli, if you happen to have 5 minutes to do this review :)
Comment 3 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-11-08 08:23:52 PST
Comment on attachment 679672 [details] [diff] [review]
Patch

I can't or shouldn't review the .java part.
Comment 4 Mounir Lamouri (:mounir) 2012-11-08 08:45:12 PST
Comment on attachment 679672 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 746142
User impact if declined: the feature is not mature enough to be added to the Web Platform. We need to figure out what we really want and have a broad discussion. Shipping this feature in Firefox Android and Firefox OS might create a situation where we are 
Testing completed (on m-c, etc.): not landing on m-c
Risk to taking this patch (and alternatives if risky): not much, unless people are already heavily relying on this feature but I doubt it. We might create regressions but that seems unlikely given that the patch tries to be very specific in removed code chunks.
String or UUID changes made by this patch: yes, nsIDOMHTMLInputElement
Comment 5 Lukas Blakk [:lsblakk] use ?needinfo 2012-11-08 09:47:04 PST
Comment on attachment 679672 [details] [diff] [review]
Patch

Approve disabling this is it's not ready yet.  Please update the status flags to 'disabled' once this is on branches.
Comment 6 Mounir Lamouri (:mounir) 2012-11-09 01:52:40 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/cb6d20b909c0
Comment 7 Mounir Lamouri (:mounir) 2012-11-09 02:13:39 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/b53dbef72a55
Comment 8 George Haddad [:georgehdd] 2012-11-21 00:15:31 PST
How come this change didn't get into the ESR ?
I have a native extension (C++) and currently I can't support both 17 release and 17 ESR. 
Do you happen to know of a workaround for this ?
Comment 9 George Haddad [:georgehdd] 2012-11-21 00:47:21 PST
It seems that FF17 Release was built with nsIDOMHTMLInputElement  with uuidd uuid(83984fd0-b0b2-11e1-afa6-0800200c9a66) and ESR had  uuid(e59a4df5-0904-414d-9203-9af2790698ea).

Help :) ?
Comment 10 Alex Keybl [:akeybl] 2012-11-21 07:58:58 PST
(In reply to georgehdd from comment #9)
> It seems that FF17 Release was built with nsIDOMHTMLInputElement  with uuidd
> uuid(83984fd0-b0b2-11e1-afa6-0800200c9a66) and ESR had 
> uuid(e59a4df5-0904-414d-9203-9af2790698ea).
> 
> Help :) ?

https://bugzilla.mozilla.org/show_bug.cgi?id=813264#c25

Note You need to log in before you can comment on or make changes to this bug.